Bug 1220497

Summary: Missing Fedora KSplash theme
Product: [Fedora] Fedora Reporter: Giulio 'juliuxpigface' <juliux.pigface>
Component: f22-kde-themeAssignee: Than Ngo <than>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: 22CC: awilliam, danofsatx, dvratil, jgrulich, jreznik, kparal, ltinkl, mbriza, rdieter, robatino, sgallagh, than
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: AcceptedFreezeException RejectedBlocker
Fixed In Version: f22-kde-theme-22.3-1.fc22 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-06-04 20:20:07 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1043132    

Description Giulio 'juliuxpigface' 2015-05-11 16:42:09 UTC
Description of problem:
Fedora's own, unique and beautiful KSplash theme is missing.

Version-Release number of selected component (if applicable):
f22-kde-theme-21.91-1.fc22.1.noarch

How reproducible:
Always

Steps to Reproduce:
1. Boot Fedora's KDE spin (either live or installed system)
2. Log in (graphical session)

Actual results:
1. The standard theme 'breeze' is displayed.


Expected results:
1. It would be nice if we provide and display a custom artwork (designed in order to fit with 22's wallpaper).

Comment 1 Fedora Blocker Bugs Application 2015-05-12 16:20:53 UTC
Proposed as a Blocker for 22-final by Fedora user dmossor using the blocker tracking app because:

 Proposed as a Blocker this directly violates Final Release Criteria: Artwork

"The proposed final Fedora artwork must be included and used as the background on release-blocking desktops. All Fedora artwork visible in critical path actions on release-blocking desktops must be consistent with the proposed final theme."

Comment 2 Adam Williamson 2015-05-12 19:46:04 UTC
-1 blocker, this does not violate that. The requirement is that the Fedora background is used (this bug doesn't say it isn't) and any Fedora artwork *that is included* is consistent with the theme - it doesn't say that all elements must have a Fedora theme.

Comment 3 Stephen Gallagher 2015-05-13 12:30:37 UTC
-1 Blocker

Comment 4 Jaroslav Reznik 2015-05-13 12:57:20 UTC
-1 blocker but I can be +1 FE even it's a bit late. All theming changed to QML with Plasma 5 and it takes time to rework what we had before...

Comment 5 Jaroslav Reznik 2015-05-13 12:58:27 UTC
(And it's not only KSplash but also lockscreen - the idea was to provide second wallpaper for lockscreens but unfortunately it wasn't designed, request came from Workstation WG)

Comment 6 Fedora Update System 2015-05-13 14:40:24 UTC
kde-settings-22-7.fc22, f22-kde-theme-22.0-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/f22-kde-theme-22.0-1.fc22,kde-settings-22-7.fc22

Comment 7 Adam Williamson 2015-05-13 21:14:03 UTC
yeah, I can be +1 FE so long as we land it ASAP.

Comment 8 Stephen Gallagher 2015-05-13 23:32:15 UTC
+1 FE

Comment 9 Kamil Páral 2015-05-14 16:18:06 UTC
Discussed at the 2015-05-14 blocker review meeting.[1] Voted as RejectedBlocker AcceptedFreezeException - we don't actually require a Fedora splash theme, but it sure would look nicer to include one if we have it, and can't be fixed for lives post-release.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2015-05-14

Comment 10 Fedora Update System 2015-05-14 22:20:43 UTC
Package kde-settings-22-7.fc22, f22-kde-theme-22.0-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kde-settings-22-7.fc22 f22-kde-theme-22.0-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-8202/f22-kde-theme-22.0-1.fc22,kde-settings-22-7.fc22
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2015-05-19 00:00:42 UTC
kde-settings-22-7.fc22, f22-kde-theme-22.0-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Jan Grulich 2015-05-21 13:28:20 UTC
Reopening, because the update above didn't fix the issue properly.

Comment 13 Fedora Update System 2015-05-21 13:28:49 UTC
f22-kde-theme-22.3-1.fc22, plasma-workspace-5.3.0-8.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/FEDORA-2015-8453/plasma-workspace-5.3.0-8.fc22,f22-kde-theme-22.3-1.fc22

Comment 14 Fedora Update System 2015-05-22 02:32:14 UTC
Package f22-kde-theme-22.3-1.fc22, plasma-desktop-5.3.0-6.fc22, plasma-workspace-5.3.0-8.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing f22-kde-theme-22.3-1.fc22 plasma-desktop-5.3.0-6.fc22 plasma-workspace-5.3.0-8.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-8453/plasma-desktop-5.3.0-6.fc22,plasma-workspace-5.3.0-8.fc22,f22-kde-theme-22.3-1.fc22
then log in and leave karma (feedback).

Comment 15 Fedora Update System 2015-06-04 20:20:07 UTC
f22-kde-theme-22.3-1.fc22, plasma-desktop-5.3.0-6.fc22, plasma-workspace-5.3.0-8.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.