Bug 1220823

Summary: add Obsoletes for retired kde4-only plasmoid pkgs
Product: [Fedora] Fedora Reporter: Rex Dieter <rdieter>
Component: kde-workspaceAssignee: Than Ngo <than>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 22CC: danofsatx, dvratil, jgrulich, jreznik, kevin, kparal, ltinkl, mbriza, rdieter, rnovacek, robatino, sgallagh, than
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedFreezeException RejectedBlocker
Fixed In Version: kde-workspace-4.11.18-3.fc22 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-05-15 21:33:15 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1043132    

Description Rex Dieter 2015-05-12 14:24:59 UTC
Found a couple more retired kde4-only packages to add Obsoletes for to help upgrades from f21, including:

kde-plasma-daisy
kde-plasma-smooth-tasks

Comment 1 Fedora Update System 2015-05-12 14:25:27 UTC
kde-workspace-4.11.18-3.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/FEDORA-2015-7972/kde-workspace-4.11.18-3.fc22

Comment 2 Fedora Blocker Bugs Application 2015-05-12 14:29:33 UTC
Proposed as a Freeze Exception for 22-final by Fedora user dmossor using the blocker tracking app because:

 This bug violates the Beta Release Requirement: Upgrade Requirements

"For each one of the release-blocking package sets, it must be possible to successfully complete an upgrade from a fully updated installation of the previous stable Fedora release with that package set installed."

Without this patch applied, users will get package conflict errors when using fedup or yum/dnf to update to F22 Plasma.

Comment 3 Stephen Gallagher 2015-05-13 21:00:09 UTC
This sounds like a blocker, not a Freeze Exception request.

If this is known to cause upgrade issues on a blocking spin, I'm +1 blocker here.

Re-proposing as blocker for appropriate review.

Comment 4 Kamil Páral 2015-05-14 16:30:17 UTC
Discussed at the 2015-05-14 blocker review meeting.[1] Voted as RejectedBlocker AcceptedFreezeException - this doesn't need to be a blocker as fedup uses the repos from the to-be-upgraded release, meaning packages from updates are almost always included, therefore this kind of issue can be fixed with a post-release update. However, accepted as an FE to help people test between now and release

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2015-05-14

Comment 5 Fedora Update System 2015-05-15 21:33:15 UTC
kde-workspace-4.11.18-3.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.