Bug 1221384

Summary: Include GNOME 3.16.2 in Fedora 22
Product: [Fedora] Fedora Reporter: Kalev Lember <kalevlember>
Component: distributionAssignee: Václav Pavlín <vpavlin>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 22CC: awilliam, dennis, kparal, notting, satellitgo, sgallagh
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedFreezeException
Fixed In Version: adwaita-icon-theme-3.16.2.1-1.fc22 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-05-18 23:57:43 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1043132    

Description Kalev Lember 2015-05-13 22:13:02 UTC
Please consider including GNOME 3.16.2 on Fedora 22 install media.

This is the final planned 3.16.x release and is strictly bugfix / translation update only, addressing many issues that were caught during F22 Beta testing.

It is a bit unfortunate that we had a schedule this cycle that put the GNOME 3.16.2 release one day after the F22 Final Freeze, but hopefully there's a way to make it work.

Thanks for the consideration!

Comment 1 Fedora Update System 2015-05-13 22:30:50 UTC
adwaita-icon-theme-3.16.2.1-1.fc22,aisleriot-3.16.2-1.fc22,bijiben-3.16.2-1.fc22,clutter-1.22.2-1.fc22,control-center-3.16.2-1.fc22,empathy-3.12.10-2.fc22,eog-3.16.2-1.fc22,epiphany-3.16.1-1.fc22,evince-3.16.0-2.fc22,evolution-3.16.2.1-1.fc22,evolution-data-server-3.16.2-2.fc22,evolution-ews-3.16.2-1.fc22,evolution-mapi-3.16.2-1.fc22,file-roller-3.16.2-1.fc22,four-in-a-row-3.16.2-1.fc22,gcr-3.16.0-1.fc22,gdk-pixbuf2-2.31.4-1.fc22,geocode-glib-3.16.2-1.fc22,glib2-2.44.1-1.fc22,gnome-boxes-3.16.2-1.fc22,gnome-calendar-3.16.2-1.fc22,gnome-characters-3.16.2-1.fc22,gnome-chess-3.16.2-1.fc22,gnome-desktop3-3.16.2-1.fc22,gnome-devel-docs-3.16.2-1.fc22,gnome-dictionary-3.16.2-1.fc22,gnome-disk-utility-3.16.1-1.fc22,gnome-documents-3.16.2-1.fc22,gnome-font-viewer-3.16.2-1.fc22,gnome-getting-started-docs-3.16.2-1.fc22,gnome-initial-setup-3.16.2-1.fc22,gnome-logs-3.16.2-1.fc22,gnome-mahjongg-3.16.1-1.fc22,gnome-maps-3.16.2-1.fc22,gnome-online-accounts-3.16.2-1.fc22,gnome-online-miners-3.14.3-1.fc22,gnome-photos-3.16.2-1.fc22,gnome-power-manager-3.16.1-2.fc22,gnome-screenshot-3.16.2-1.fc22,gnome-settings-daemon-3.16.2-1.fc22,gnome-software-3.16.2-1.fc22,gnome-terminal-3.16.2-1.fc22,gnome-themes-standard-3.16.2-1.fc22,gnome-tweak-tool-3.16.2-1.fc22,gtk-doc-1.22-1.fc22,gtk2-2.24.28-1.fc22,gtk3-3.16.3-1.fc22,gucharmap-3.16.2-1.fc22,gupnp-0.20.14-1.fc22,gupnp-tools-0.8.10-1.fc22,nautilus-3.16.2-1.fc22,orca-3.16.2-1.fc22,quadrapassel-3.16.1-1.fc22,rygel-0.26.1-1.fc22,seahorse-3.16.0-1.fc22,simple-scan-3.16.2-1.fc22,sushi-3.16.0-1.fc22,tali-3.16.1-1.fc22,vinagre-3.16.1-1.fc22,vte291-0.40.2-1.fc22,yelp-3.16.1-1.fc22,zenity-3.16.0-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/adwaita-icon-theme-3.16.2.1-1.fc22,aisleriot-3.16.2-1.fc22,bijiben-3.16.2-1.fc22,clutter-1.22.2-1.fc22,control-center-3.16.2-1.fc22,empathy-3.12.10-2.fc22,eog-3.16.2-1.fc22,epiphany-3.16.1-1.fc22,evince-3.16.0-2.fc22,evolution-3.16.2.1-1.fc22,evolution-data-server-3.16.2-2.fc22,evolution-ews-3.16.2-1.fc22,evolution-mapi-3.16.2-1.fc22,file-roller-3.16.2-1.fc22,four-in-a-row-3.16.2-1.fc22,gcr-3.16.0-1.fc22,gdk-pixbuf2-2.31.4-1.fc22,geocode-glib-3.16.2-1.fc22,glib2-2.44.1-1.fc22,gnome-boxes-3.16.2-1.fc22,gnome-calendar-3.16.2-1.fc22,gnome-characters-3.16.2-1.fc22,gnome-chess-3.16.2-1.fc22,gnome-desktop3-3.16.2-1.fc22,gnome-devel-docs-3.16.2-1.fc22,gnome-dictionary-3.16.2-1.fc22,gnome-disk-utility-3.16.1-1.fc22,gnome-documents-3.16.2-1.fc22,gnome-font-viewer-3.16.2-1.fc22,gnome-getting-started-docs-3.16.2-1.fc22,gnome-initial-setup-3.16.2-1.fc22,gnome-logs-3.16.2-1.fc22,gnome-mahjongg-3.16.1-1.fc22,gnome-maps-3.16.2-1.fc22,gnome-online-accounts-3.16.2-1.fc22,gnome-online-miners-3.14.3-1.fc22,gnome-photos-3.16.2-1.fc22,gnome-power-manager-3.16.1-2.fc22,gnome-screenshot-3.16.2-1.fc22,gnome-settings-daemon-3.16.2-1.fc22,gnome-software-3.16.2-1.fc22,gnome-terminal-3.16.2-1.fc22,gnome-themes-standard-3.16.2-1.fc22,gnome-tweak-tool-3.16.2-1.fc22,gtk-doc-1.22-1.fc22,gtk2-2.24.28-1.fc22,gtk3-3.16.3-1.fc22,gucharmap-3.16.2-1.fc22,gupnp-0.20.14-1.fc22,gupnp-tools-0.8.10-1.fc22,nautilus-3.16.2-1.fc22,orca-3.16.2-1.fc22,quadrapassel-3.16.1-1.fc22,rygel-0.26.1-1.fc22,seahorse-3.16.0-1.fc22,simple-scan-3.16.2-1.fc22,sushi-3.16.0-1.fc22,tali-3.16.1-1.fc22,vinagre-3.16.1-1.fc22,vte291-0.40.2-1.fc22,yelp-3.16.1-1.fc22,zenity-3.16.0-1.fc22

Comment 2 Adam Williamson 2015-05-13 23:14:04 UTC
FWIW I built a live image with the mega-update and ran it through a few simple tests and it's working OK so far. g-i-s is OK, firefox, terminal, control-center, update notification...

Comment 3 Stephen Gallagher 2015-05-13 23:50:54 UTC
So, I hate to be the stop-energy here, but I'm going to vote -1 freeze exception.

Our guidelines for freeze extensions (https://fedoraproject.org/wiki/QA:SOP_freeze_exception_bug_process#Freeze_exception_bug_principles) state:

"In general, freeze exception bugs are usually bugs for which an update is not an optimal solution, and for which the fix is reasonably small and testable (this consideration becomes progressively more important as a release nears"

I haven't seen an argument that solving this via a post-release update would be insufficient. This change is *not* small (though "testable" is arguable, since much of the content is covered in release validation).

I'd much prefer that we stick with the existing stable packages and only pull in additional changes on a case-by-case basis for blockers.

It's unfortunate that GNOME upstream's schedule didn't align with Fedora's, but our schedule has been posted for a long time (and was originally a week shorter, which would have bypassed this question entirely). Allowing in a "megaupdate" after Freeze basically defeats the entire purpose of having a freeze.

Comment 4 Kamil Páral 2015-05-14 17:18:54 UTC
Discussed at the 2015-05-14 blocker review meeting.[1] Voted as AcceptedFreezeException - this fixes some visible issues on the live image (symbolic icons and translations, mainly) and we would prefer to try and land it in the final images over having a large 0-day update. The update will not be pushed stable unless TC4 desktop validation succeeds

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2015-05-14

Comment 5 Fedora Update System 2015-05-14 22:21:27 UTC
Package adwaita-icon-theme-3.16.2.1-1.fc22, aisleriot-3.16.2-1.fc22, bijiben-3.16.2-1.fc22, clutter-1.22.2-1.fc22, control-center-3.16.2-1.fc22, empathy-3.12.10-2.fc22, eog-3.16.2-1.fc22, epiphany-3.16.1-1.fc22, evince-3.16.0-2.fc22, evolution-3.16.2.1-1.fc22, evolution-data-server-3.16.2-2.fc22, evolution-ews-3.16.2-1.fc22, evolution-mapi-3.16.2-1.fc22, file-roller-3.16.2-1.fc22, four-in-a-row-3.16.2-1.fc22, gcr-3.16.0-1.fc22, gdk-pixbuf2-2.31.4-1.fc22, geocode-glib-3.16.2-1.fc22, glib2-2.44.1-1.fc22, gnome-boxes-3.16.2-1.fc22, gnome-calendar-3.16.2-1.fc22, gnome-characters-3.16.2-1.fc22, gnome-chess-3.16.2-1.fc22, gnome-desktop3-3.16.2-1.fc22, gnome-devel-docs-3.16.2-1.fc22, gnome-dictionary-3.16.2-1.fc22, gnome-disk-utility-3.16.1-1.fc22, gnome-documents-3.16.2-1.fc22, gnome-font-viewer-3.16.2-1.fc22, gnome-getting-started-docs-3.16.2-1.fc22, gnome-initial-setup-3.16.2-1.fc22, gnome-logs-3.16.2-1.fc22, gnome-mahjongg-3.16.1-1.fc22, gnome-maps-3.16.2-1.fc22, gnome-online-accounts-3.16.2-1.fc22, gnome-online-miners-3.14.3-1.fc22, gnome-photos-3.16.2-1.fc22, gnome-power-manager-3.16.1-2.fc22, gnome-screenshot-3.16.2-1.fc22, gnome-settings-daemon-3.16.2-1.fc22, gnome-software-3.16.2-1.fc22, gnome-terminal-3.16.2-1.fc22, gnome-themes-standard-3.16.2-1.fc22, gnome-tweak-tool-3.16.2-1.fc22, gtk-doc-1.22-1.fc22, gtk2-2.24.28-1.fc22, gtk3-3.16.3-1.fc22, gucharmap-3.16.2-1.fc22, gupnp-0.20.14-1.fc22, gupnp-tools-0.8.10-1.fc22, nautilus-3.16.2-1.fc22, orca-3.16.2-1.fc22, quadrapassel-3.16.1-1.fc22, rygel-0.26.1-1.fc22, seahorse-3.16.0-1.fc22, simple-scan-3.16.2-1.fc22, sushi-3.16.0-1.fc22, tali-3.16.1-1.fc22, vinagre-3.16.1-1.fc22, vte291-0.40.2-1.fc22, yelp-3.16.1-1.fc22, zenity-3.16.0-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing adwaita-icon-theme-3.16.2.1-1.fc22 aisleriot-3.16.2-1.fc22 bijiben-3.16.2-1.fc22 clutter-1.22.2-1.fc22 control-center-3.16.2-1.fc22 empathy-3.12.10-2.fc22 eog-3.16.2-1.fc22 epiphany-3.16.1-1.fc22 evince-3.16.0-2.fc22 evolution-3.16.2.1-1.fc22 evolution-data-server-3.16.2-2.fc22 evolution-ews-3.16.2-1.fc22 evolution-mapi-3.16.2-1.fc22 file-roller-3.16.2-1.fc22 four-in-a-row-3.16.2-1.fc22 gcr-3.16.0-1.fc22 gdk-pixbuf2-2.31.4-1.fc22 geocode-glib-3.16.2-1.fc22 glib2-2.44.1-1.fc22 gnome-boxes-3.16.2-1.fc22 gnome-calendar-3.16.2-1.fc22 gnome-characters-3.16.2-1.fc22 gnome-chess-3.16.2-1.fc22 gnome-desktop3-3.16.2-1.fc22 gnome-devel-docs-3.16.2-1.fc22 gnome-dictionary-3.16.2-1.fc22 gnome-disk-utility-3.16.1-1.fc22 gnome-documents-3.16.2-1.fc22 gnome-font-viewer-3.16.2-1.fc22 gnome-getting-started-docs-3.16.2-1.fc22 gnome-initial-setup-3.16.2-1.fc22 gnome-logs-3.16.2-1.fc22 gnome-mahjongg-3.16.1-1.fc22 gnome-maps-3.16.2-1.fc22 gnome-online-accounts-3.16.2-1.fc22 gnome-online-miners-3.14.3-1.fc22 gnome-photos-3.16.2-1.fc22 gnome-power-manager-3.16.1-2.fc22 gnome-screenshot-3.16.2-1.fc22 gnome-settings-daemon-3.16.2-1.fc22 gnome-software-3.16.2-1.fc22 gnome-terminal-3.16.2-1.fc22 gnome-themes-standard-3.16.2-1.fc22 gnome-tweak-tool-3.16.2-1.fc22 gtk-doc-1.22-1.fc22 gtk2-2.24.28-1.fc22 gtk3-3.16.3-1.fc22 gucharmap-3.16.2-1.fc22 gupnp-0.20.14-1.fc22 gupnp-tools-0.8.10-1.fc22 nautilus-3.16.2-1.fc22 orca-3.16.2-1.fc22 quadrapassel-3.16.1-1.fc22 rygel-0.26.1-1.fc22 seahorse-3.16.0-1.fc22 simple-scan-3.16.2-1.fc22 sushi-3.16.0-1.fc22 tali-3.16.1-1.fc22 vinagre-3.16.1-1.fc22 vte291-0.40.2-1.fc22 yelp-3.16.1-1.fc22 zenity-3.16.0-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-8219/adwaita-icon-theme-3.16.2.1-1.fc22,aisleriot-3.16.2-1.fc22,bijiben-3.16.2-1.fc22,clutter-1.22.2-1.fc22,control-center-3.16.2-1.fc22,empathy-3.12.10-2.fc22,eog-3.16.2-1.fc22,epiphany-3.16.1-1.fc22,evince-3.16.0-2.fc22,evolution-3.16.2.1-1.fc22,evolution-data-server-3.16.2-2.fc22,evolution-ews-3.16.2-1.fc22,evolution-mapi-3.16.2-1.fc22,file-roller-3.16.2-1.fc22,four-in-a-row-3.16.2-1.fc22,gcr-3.16.0-1.fc22,gdk-pixbuf2-2.31.4-1.fc22,geocode-glib-3.16.2-1.fc22,glib2-2.44.1-1.fc22,gnome-boxes-3.16.2-1.fc22,gnome-calendar-3.16.2-1.fc22,gnome-characters-3.16.2-1.fc22,gnome-chess-3.16.2-1.fc22,gnome-desktop3-3.16.2-1.fc22,gnome-devel-docs-3.16.2-1.fc22,gnome-dictionary-3.16.2-1.fc22,gnome-disk-utility-3.16.1-1.fc22,gnome-documents-3.16.2-1.fc22,gnome-font-viewer-3.16.2-1.fc22,gnome-getting-started-docs-3.16.2-1.fc22,gnome-initial-setup-3.16.2-1.fc22,gnome-logs-3.16.2-1.fc22,gnome-mahjongg-3.16.1-1.fc22,gnome-maps-3.16.2-1.fc22,gnome-online-accounts-3.16.2-1.fc22,gnome-online-miners-3.14.3-1.fc22,gnome-photos-3.16.2-1.fc22,gnome-power-manager-3.16.1-2.fc22,gnome-screenshot-3.16.2-1.fc22,gnome-settings-daemon-3.16.2-1.fc22,gnome-software-3.16.2-1.fc22,gnome-terminal-3.16.2-1.fc22,gnome-themes-standard-3.16.2-1.fc22,gnome-tweak-tool-3.16.2-1.fc22,gtk-doc-1.22-1.fc22,gtk2-2.24.28-1.fc22,gtk3-3.16.3-1.fc22,gucharmap-3.16.2-1.fc22,gupnp-0.20.14-1.fc22,gupnp-tools-0.8.10-1.fc22,nautilus-3.16.2-1.fc22,orca-3.16.2-1.fc22,quadrapassel-3.16.1-1.fc22,rygel-0.26.1-1.fc22,seahorse-3.16.0-1.fc22,simple-scan-3.16.2-1.fc22,sushi-3.16.0-1.fc22,tali-3.16.1-1.fc22,vinagre-3.16.1-1.fc22,vte291-0.40.2-1.fc22,yelp-3.16.1-1.fc22,zenity-3.16.0-1.fc22
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2015-05-18 23:57:43 UTC
adwaita-icon-theme-3.16.2.1-1.fc22, aisleriot-3.16.2-1.fc22, bijiben-3.16.2-1.fc22, clutter-1.22.2-1.fc22, control-center-3.16.2-1.fc22, empathy-3.12.10-2.fc22, eog-3.16.2-1.fc22, epiphany-3.16.1-1.fc22, evince-3.16.0-2.fc22, evolution-3.16.2.1-1.fc22, evolution-data-server-3.16.2-2.fc22, evolution-ews-3.16.2-1.fc22, evolution-mapi-3.16.2-1.fc22, file-roller-3.16.2-1.fc22, four-in-a-row-3.16.2-1.fc22, gcr-3.16.0-1.fc22, gdk-pixbuf2-2.31.4-1.fc22, geocode-glib-3.16.2-1.fc22, glib2-2.44.1-1.fc22, gnome-boxes-3.16.2-1.fc22, gnome-calendar-3.16.2-1.fc22, gnome-characters-3.16.2-1.fc22, gnome-chess-3.16.2-1.fc22, gnome-desktop3-3.16.2-1.fc22, gnome-devel-docs-3.16.2-1.fc22, gnome-dictionary-3.16.2-1.fc22, gnome-disk-utility-3.16.1-1.fc22, gnome-documents-3.16.2-1.fc22, gnome-font-viewer-3.16.2-1.fc22, gnome-getting-started-docs-3.16.2-1.fc22, gnome-initial-setup-3.16.2-1.fc22, gnome-logs-3.16.2-1.fc22, gnome-mahjongg-3.16.1-1.fc22, gnome-maps-3.16.2-1.fc22, gnome-online-accounts-3.16.2-1.fc22, gnome-online-miners-3.14.3-1.fc22, gnome-photos-3.16.2-1.fc22, gnome-power-manager-3.16.1-2.fc22, gnome-screenshot-3.16.2-1.fc22, gnome-settings-daemon-3.16.2-1.fc22, gnome-software-3.16.2-1.fc22, gnome-terminal-3.16.2-1.fc22, gnome-themes-standard-3.16.2-1.fc22, gnome-tweak-tool-3.16.2-1.fc22, gtk-doc-1.22-1.fc22, gtk2-2.24.28-1.fc22, gtk3-3.16.3-1.fc22, gucharmap-3.16.2-1.fc22, gupnp-0.20.14-1.fc22, gupnp-tools-0.8.10-1.fc22, nautilus-3.16.2-1.fc22, orca-3.16.2-1.fc22, quadrapassel-3.16.1-1.fc22, rygel-0.26.1-1.fc22, seahorse-3.16.0-1.fc22, simple-scan-3.16.2-1.fc22, sushi-3.16.0-1.fc22, tali-3.16.1-1.fc22, vinagre-3.16.1-1.fc22, vte291-0.40.2-1.fc22, yelp-3.16.1-1.fc22, zenity-3.16.0-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.