Bug 1222134

Summary: Fix the default for gnome-shell's "Install pending software updates" checkbox
Product: [Fedora] Fedora Reporter: Kalev Lember <kalevlember>
Component: PackageKitAssignee: Richard Hughes <rhughes>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 22CC: jonathan, kalevlember, pschindl, rdieter, rhughes, smparrish
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedFreezeException
Fixed In Version: PackageKit-1.0.6-3.fc22 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-05-18 23:57:25 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1043132    

Description Kalev Lember 2015-05-15 20:48:47 UTC
kparal pointed out on IRC the other day that F22 gnome-shell has the "Install pending software updates" checkbox always checked, by default. We hadn't deliberately changed the default, so I set out to investigate.

It turned out to be a fallout from an unrelated PackageKit commit that, as a side effect, accidentally flipped the default value for the gnome-shell checkbox.

I would like to fix this and change this back to the way it was intended before GA, so that we can stick with the same default value throughout the F22 life cycle -- I don't think users would appreciate if we changed the default in a 0 day update.

Comment 1 Fedora Update System 2015-05-15 20:53:45 UTC
PackageKit-1.0.6-3.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/PackageKit-1.0.6-3.fc22

Comment 2 Fedora Update System 2015-05-16 10:32:41 UTC
Package PackageKit-1.0.6-3.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing PackageKit-1.0.6-3.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-8326/PackageKit-1.0.6-3.fc22
then log in and leave karma (feedback).

Comment 3 Petr Schindler 2015-05-18 18:00:46 UTC
Discussed at today's blocker review meeting [1]. 

This bug was accepted as freeze exception: It would be good to get this fix pulled in for F22.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2015-05-18

Comment 4 Fedora Update System 2015-05-18 23:57:25 UTC
PackageKit-1.0.6-3.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.