Bug 1223477

Summary: xorg-x11-drv-intel: upstream recommends Disable DRI3
Product: [Fedora] Fedora Reporter: Rex Dieter <rdieter>
Component: xorg-x11-drv-intelAssignee: Adam Jackson <ajax>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 22CC: ajax, helio, xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: xorg-x11-drv-intel-2.99.917-9.20150520.fc22 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-05-27 16:22:12 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1193742    

Description Rex Dieter 2015-05-20 15:25:09 UTC
Since upstream commit,
http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?id=b6eeb7a1f7efa591504070b606be655e27e6e9c2

Disable DRI3 by default

The external libraries, both in git, and especially shipping already
enabled in distributions, are buggy and lead to server crashes and
lockups. Caveat emptor.


fedora's intel driver currently explicitly enables DRI3 with configure option:
 --with-default-dri=3

Comment 1 Fedora Update System 2015-05-20 17:16:24 UTC
xorg-x11-drv-intel-2.99.917-9.20150520.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/xorg-x11-drv-intel-2.99.917-9.20150520.fc22

Comment 2 Fedora Update System 2015-05-21 00:16:24 UTC
Package xorg-x11-drv-intel-2.99.917-9.20150520.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-drv-intel-2.99.917-9.20150520.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-8616/xorg-x11-drv-intel-2.99.917-9.20150520.fc22
then log in and leave karma (feedback).

Comment 3 Fedora Update System 2015-05-27 16:22:12 UTC
xorg-x11-drv-intel-2.99.917-9.20150520.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.