Bug 1226615

Summary: Quick Outline (Ctrl+O) doesn't work (Outline is closed immediately)
Product: [Fedora] Fedora Reporter: Hedayat Vatankhah <hedayatv>
Component: eclipseAssignee: Alexander Kurtakov <akurtako>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 22CC: akurtako, andjrobins, eclipse-sig, jerboaa, jjohnstn, krzysztof.daniel, mat.booth, rgrunber, swagiaal
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-04-16 04:37:02 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Hedayat Vatankhah 2015-05-31 05:13:54 UTC
Description of problem:
Eclipse in Fedora 22 has many problems (actually, mostly about its color theme which is unreadable/unnoticable in some places), but one of the most annoying ones is that the Quick Outline view (Ctrl+O) doesn't work. It does open the outline window, but it is closed immediately. Also, it has a black background while it was yellow (IIRC) in F21; but this is not that important.

Comment 1 Hedayat Vatankhah 2015-05-31 06:17:10 UTC
Well, the problem is not only with the quick outline view, but with any "pop-up" windows which should appear. As a result, Ctrl+F7 and Ctrl+F8 also doesn't work (and they may cause the keyboard to be captured in some invisible window so that most keys doesn't work anymore until I try to close Eclipse).

This problem is really annoying, and reducing productivity.

Comment 2 Mat Booth 2015-06-03 21:26:35 UTC
Hmm, I am not experiencing this problem. My only problem is that the view and perspective switch pop-ups are too small to see all options.

Do you have the latest eclipse installed? What is the output of:

$ rpm -q eclipse-platform

Comment 3 Hedayat Vatankhah 2015-06-04 15:35:47 UTC
Yes, I think so:
eclipse-platform-4.4.2-6.fc22.x86_64

As you said you don't experience this problem, I tested more and this is the results:
1. Notice that I've experienced this problem on 2 systems, both of which has almost the same packages (and similar configurations since I've configured both). Also, on both of them I use a fresh Fedora 22 installation, but with a /home partition remaining from previous releases. Therefore, the user's home directory is not fresh. 

2. I tried creating a new user with a fresh home directory. I don't see this problem there. Everything works fine as you said (and yes, perspective switch is small; but view was OK for me!). 

3. In my main user, I tried renaming ~/.eclipse and run eclipse to use a new workspace. However, I still have the same issue!

I don't know how to debug this problem further, it could be some Gnome or GTK settings remaining from older versions of them. Any suggestions?!

Comment 4 Hedayat Vatankhah 2015-06-06 07:06:49 UTC
Removing ~/.config/dconf/ solves the issue.

Comment 5 Hedayat Vatankhah 2015-06-06 10:14:47 UTC
I found it! It is related to "Input sources" configuration. If you enable "per window" input source selection, you'll see this behavior. If you disable it (enable global input source selection), the problem will be solved.

Comment 6 Alexander Kurtakov 2015-06-08 08:57:36 UTC
Where is this configuration? I'm interested to learn more as eclipe should not break that way due to user configuration.

Comment 7 Hedayat Vatankhah 2015-06-08 17:56:05 UTC
In Gnome:
Settings->Region & Language->Options->Allow different sources for each window

Notice that you probably should have at least two input sources in Region & Language settings panel enabled.

Comment 8 Hedayat Vatankhah 2016-04-16 04:37:02 UTC
This problem is solved in F23. However, there are some other problems both in eclipse and outside it which are caused by the same settings. Therefore, it is probably not an eclipse bug at all, but a GTK and/or IBus bug.