Bug 1231986
| Summary: | Clicking fleeced "Init processes" on an image summary screen triggers an error. | ||
|---|---|---|---|
| Product: | Red Hat CloudForms Management Engine | Reporter: | John Prause <jprause> |
| Component: | UI - OPS | Assignee: | Dan Clarizio <dclarizi> |
| Status: | CLOSED ERRATA | QA Contact: | Milan Falešník <mfalesni> |
| Severity: | medium | Docs Contact: | |
| Priority: | high | ||
| Version: | 5.4.0 | CC: | cpelland, dajohnso, dclarizi, drieden, gblomqui, hkataria, jhardy, jprause, mfalesni, mfeifer, mhradil, mpovolny, obarenbo, rananda, ssainkar, tcarlin |
| Target Milestone: | GA | Keywords: | ZStream |
| Target Release: | 5.4.1 | ||
| Hardware: | Unspecified | ||
| OS: | Unspecified | ||
| Whiteboard: | |||
| Fixed In Version: | 5.4.1.0 | Doc Type: | Bug Fix |
| Doc Text: |
During Red Hat OpenStack infrastructure integration, clicking fleeced Init Processes on an image summary screen threw an error: undefined method `name' for nil:NilClass [vm_cloud/explorer
This bug has been fixed by making show_association use controller_to_model when retrieving @record. This makes linux_initprocesses (and others) load from VmOrTemplate, not VmCloud - without it, /vm_cloud/linux_initprocesses/119 tries to load VmCloud(id=119) and not VmOrTemplate(id=119) in CiProcessing#show_association. This has been broken since ec1389e which unified all the show_association methods, without the special @record load handling that was present in VmCommon. Without it, a load from VmCloud is attempted instead of VmOrTemplate, and fails. This likely affects all show_association calls made from vm_common - Running Processes, Registry Entries, Advanced Settings, Init Processes, Win32 Services, Kernel Drivers, File System Drivers, Files and Security Groups.
|
Story Points: | --- |
| Clone Of: | 1211665 | Environment: | |
| Last Closed: | 2015-07-30 13:11:49 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
| Bug Depends On: | 1211665, 1243418 | ||
| Bug Blocks: | |||
|
Comment 3
Milan Falešník
2015-07-21 09:03:03 UTC
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory, and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://rhn.redhat.com/errata/RHBA-2015-1511.html |