Bug 1233280

Summary: Don't enforce KDE logging rules on all Qt applications
Product: [Fedora] Fedora Reporter: Alex <alexander.blasche>
Component: kde-settingsAssignee: Rex Dieter <rdieter>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 22CC: dvratil, jgrulich, jreznik, kai.koehne, kevin, ltinkl, mbriza, rdieter, rnovacek, smparrish, than
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-06-18 17:41:08 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Alex 2015-06-18 15:15:01 UTC
User-Agent:       Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build Identifier: 

/etc/xdg/QtProject/qtlogging.ini is a KDE specific logging configuration for QDebug. However in the current setup it forces all other non-KDE applications to not print any debugging output. This happens no matter whether the system Qt is used or your own Qt deployment (as in my own case - developing Qt itself).

Reproducible: Always

Steps to Reproduce:
1. Compile an arbitrary Qt (non-KDE) application with qDebug()
2. Run app
3. Observe the console output
Actual Results:  
No QDebug output is printed to the console

Comment 1 Rex Dieter 2015-06-18 15:17:51 UTC
It not KDE specific.

It's a distro-wide policy decision that our optimized Release builds of Qt should not enable debug logging by default.

You're free to override that by using a customized ~/.config/QtProject/qtlogging.ini or modify /etc/xdg/QtProject/qtlogging.ini as you see fit.

Comment 2 Rex Dieter 2015-06-18 15:19:41 UTC
Well, you're right that this affects *all* installed copies of Qt, not just our packaged versions.

I figured using a global qtlogging.ini was easier than patching Qt though.

Suggestions welcome.

Comment 3 Kevin Kofler 2015-06-18 17:41:08 UTC
As Rex Dieter explained, this is a Fedora policy decision, not a KDE one. qt-settings just happens to be a subpackage of the kde-settings SRPM in Fedora, for historical and convenience reasons. But all those *-settings are Fedora settings and do not come from KDE upstream.

*** This bug has been marked as a duplicate of bug 1227295 ***