Bug 1234743

Summary: Ctrl+K not working when caret is inside an input
Product: [Fedora] Fedora Reporter: Yajo <yajo.sk8>
Component: firefoxAssignee: Martin Stransky <stransky>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 22CC: gecko-bugs-nobody, jhorak, stransky
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-06-23 07:45:16 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Yajo 2015-06-23 07:35:25 UTC
Description of problem:
Ctrl+K shortcut for Firefox no longer goes to the search box when the caret is inside an <input> in any page.


Version-Release number of selected component (if applicable):
firefox-38.0.5-2.fc22.x86_64


How reproducible:
Always.


Steps to Reproduce:
1. Go to any page that has an <input>.
2. Select that input.
3. Press Ctrl+K.


Actual results:
Nothing happens.


Expected results:
Select search box (https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly?redirectlocale=en-US&redirectslug=Keyboard+shortcuts#w_search)


Additional info:
Ctrl+J works fine.
Ctrl+K works in Windows on same FF version.
When in the address bar, Ctrl+K clears it (It should act as Ctrl+J).
I could get used to Ctrl+J, but this seems a bug anyway. Ctrl+K should work everywhere as it has been always, not just outside inputs.

Comment 1 Martin Stransky 2015-06-23 07:45:16 UTC
Unfortunately that's a Gtk3 bug and we can't fix that (at least I don't know how). See Bug 1224605 for workaround.

*** This bug has been marked as a duplicate of bug 1224605 ***