Bug 1236210

Summary: jenkins: Missing requires on unzip
Product: [Fedora] Fedora Reporter: Mikolaj Izdebski <mizdebsk>
Component: jenkinsAssignee: Michal Srb <msrb>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 22CC: java-sig-commits, mizdebsk, msrb
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: jenkins-matrix-project-plugin-1.6-1.fc22 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-07-16 02:34:19 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Mikolaj Izdebski 2015-06-26 20:14:41 UTC
Description of problem:
Jenkins fails to install packaged plugins with the following error:

SEVERE: Failed to unzip plugin /var/lib/jenkins/plugins/ssh-slaves.jpi
java.io.IOException: Cannot run program "/usr/bin/unzip": error=2, No such file or directory
        at java.lang.ProcessBuilder.start(ProcessBuilder.java:1048)
        at java.lang.Runtime.exec(Runtime.java:620)
        at java.lang.Runtime.exec(Runtime.java:450)
        at java.lang.Runtime.exec(Runtime.java:347)
        at hudson.ClassicPluginStrategy.unzipExceptClasses(ClassicPluginStrategy.java:595)
        at hudson.ClassicPluginStrategy.explode(ClassicPluginStrategy.java:526)
        at hudson.ClassicPluginStrategy.createPluginWrapper(ClassicPluginStrategy.java:166)
        at hudson.PluginManager$1$3$1.run(PluginManager.java:253)
        at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
        at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
        at jenkins.model.Jenkins$7.runTask(Jenkins.java:904)
        at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
        at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
        at java.lang.Thread.run(Thread.java:745)
Caused by: java.io.IOException: error=2, No such file or directory
        at java.lang.UNIXProcess.forkAndExec(Native Method)
        at java.lang.UNIXProcess.<init>(UNIXProcess.java:248)
        at java.lang.ProcessImpl.start(ProcessImpl.java:134)
        at java.lang.ProcessBuilder.start(ProcessBuilder.java:1029)
        ... 15 more

Version-Release number of selected component (if applicable):
jenkins-1.609-4.fc22.noarch

Comment 1 Fedora Update System 2015-06-30 09:27:21 UTC
jenkins-ssh-credentials-plugin-1.11-1.fc22,jenkins-matrix-project-plugin-1.6-1.fc22,jenkins-antisamy-markup-formatter-plugin-1.3-1.fc22,jenkins-script-security-plugin-1.14-1.fc22,jenkins-matrix-auth-plugin-1.2-1.fc22,jenkins-ldap-plugin-1.11-1.fc22,jenkins-junit-plugin-1.6-1.fc22,jenkins-ant-plugin-1.2-4.fc22,maven-hpi-plugin-1.113-2.fc22,jenkins-instance-identity-1.4-4.fc22,jenkins-1.609.1-4.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/jenkins-ssh-credentials-plugin-1.11-1.fc22,jenkins-matrix-project-plugin-1.6-1.fc22,jenkins-antisamy-markup-formatter-plugin-1.3-1.fc22,jenkins-script-security-plugin-1.14-1.fc22,jenkins-matrix-auth-plugin-1.2-1.fc22,jenkins-ldap-plugin-1.11-1.fc22,jenkins-junit-plugin-1.6-1.fc22,jenkins-ant-plugin-1.2-4.fc22,maven-hpi-plugin-1.113-2.fc22,jenkins-instance-identity-1.4-4.fc22,jenkins-1.609.1-4.fc22

Comment 2 Fedora Update System 2015-06-30 20:21:47 UTC
Package jenkins-matrix-project-plugin-1.6-1.fc22, jenkins-script-security-plugin-1.14-1.fc22, jenkins-ldap-plugin-1.11-1.fc22, jenkins-ant-plugin-1.2-4.fc22, jenkins-instance-identity-1.4-4.fc22, jenkins-ssh-credentials-plugin-1.11-1.fc22, jenkins-antisamy-markup-formatter-plugin-1.3-1.fc22, jenkins-matrix-auth-plugin-1.2-1.fc22, jenkins-junit-plugin-1.6-1.fc22, maven-hpi-plugin-1.113-2.fc22, jenkins-1.609.1-4.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing jenkins-matrix-project-plugin-1.6-1.fc22 jenkins-script-security-plugin-1.14-1.fc22 jenkins-ldap-plugin-1.11-1.fc22 jenkins-ant-plugin-1.2-4.fc22 jenkins-instance-identity-1.4-4.fc22 jenkins-ssh-credentials-plugin-1.11-1.fc22 jenkins-antisamy-markup-formatter-plugin-1.3-1.fc22 jenkins-matrix-auth-plugin-1.2-1.fc22 jenkins-junit-plugin-1.6-1.fc22 maven-hpi-plugin-1.113-2.fc22 jenkins-1.609.1-4.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-10985/jenkins-ssh-credentials-plugin-1.11-1.fc22,jenkins-matrix-project-plugin-1.6-1.fc22,jenkins-antisamy-markup-formatter-plugin-1.3-1.fc22,jenkins-script-security-plugin-1.14-1.fc22,jenkins-matrix-auth-plugin-1.2-1.fc22,jenkins-ldap-plugin-1.11-1.fc22,jenkins-junit-plugin-1.6-1.fc22,jenkins-ant-plugin-1.2-4.fc22,maven-hpi-plugin-1.113-2.fc22,jenkins-instance-identity-1.4-4.fc22,jenkins-1.609.1-4.fc22
then log in and leave karma (feedback).

Comment 3 Fedora Update System 2015-07-16 02:34:19 UTC
jenkins-matrix-project-plugin-1.6-1.fc22, jenkins-script-security-plugin-1.14-1.fc22, jenkins-ldap-plugin-1.11-1.fc22, jenkins-ant-plugin-1.2-4.fc22, jenkins-instance-identity-1.4-4.fc22, jenkins-ssh-credentials-plugin-1.11-1.fc22, jenkins-antisamy-markup-formatter-plugin-1.3-1.fc22, jenkins-matrix-auth-plugin-1.2-1.fc22, jenkins-junit-plugin-1.6-1.fc22, maven-hpi-plugin-1.113-2.fc22, jenkins-1.609.1-4.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.