Bug 1236480

Summary: foreman-debug to collect foreman http request log
Product: Red Hat Satellite Reporter: Pavel Moravec <pmoravec>
Component: OtherAssignee: Chris Roberts <chrobert>
Status: CLOSED CURRENTRELEASE QA Contact: sthirugn <sthirugn>
Severity: medium Docs Contact:
Priority: low    
Version: 6.1.0CC: bbuckingham, bkearney, chrobert, cwelton, sthirugn
Target Milestone: UnspecifiedKeywords: Triaged
Target Release: Unused   
Hardware: All   
OS: Linux   
URL: http://projects.theforeman.org/issues/10945
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-08-12 16:03:21 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Pavel Moravec 2015-06-29 07:57:07 UTC
Description of problem:
Please collect foreman http request log: /var/log/httpd/foreman-ssl_access_ssl.log as it is valuable in several debugging situations, esp. external capsule / content host <-> Sat6 communication problems either due to SSL or proxy issues.


Version-Release number of selected component (if applicable):
foreman-debug-1.7.2.27-1.el7sat.noarch


How reproducible:
100%


Steps to Reproduce:
1. foreman-debug
2. Check if /var/log/httpd/foreman-ssl_access_ssl.log is collected in tarball


Actual results:
The http request log is not collected


Expected results:
The file to be collected


Additional info:

Comment 2 Pavel Moravec 2015-06-29 08:33:23 UTC
PR: https://github.com/theforeman/foreman/pull/2497

Comment 3 Bryan Kearney 2015-06-29 14:04:58 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/10945 has been closed
-------------
Pavel Moravec
PR: https://github.com/theforeman/foreman/pull/2497
-------------
Pavel Moravec
Applied in changeset commit:834d221b9bb5ff6149fdb2bb0cfc92e8a499e2f9.

Comment 5 Bryan Kearney 2015-07-10 20:26:43 UTC
Delivered with Snap12.

Comment 6 sthirugn@redhat.com 2015-07-10 21:16:02 UTC
Verified in Sat 6.1 GA.  /var/log/httpd/foreman-ssl_access_ssl.log is now stored in foreman-debug.

Comment 7 Bryan Kearney 2015-08-12 16:03:21 UTC
This bug was fixed in Satellite 6.1.1 which was delivered on 12 August, 2015.