Bug 1237013

Summary: when boot a RHEL7.2 64 bit guest the mouse cursor (ps/2 or usb-mouse)in guest disappears
Product: Red Hat Enterprise Linux 7 Reporter: Yanhui Ma <yama>
Component: xorg-x11-serverAssignee: Adam Jackson <ajax>
Status: CLOSED ERRATA QA Contact: Desktop QE <desktop-qa-list>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.2CC: areis, huding, juzhang, knoel, kraxel, tpelka, virt-maint, xfu
Target Milestone: rc   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: xorg-x11-server-1.17.2-7.el7 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-11-19 04:27:25 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Yanhui Ma 2015-06-30 07:58:28 UTC
Description of problem:
When boot a RHEL7.2 64 bit guest the mouse in guest disappears, but after opening an application (e.g. terminal) the mouse could appear.
When boot a RHEL7.0 guest the mouse works well in guest.

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-2.3.0-5.el7.x86_64
3.10.0-278.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.boot a guest with the following qemu command:
/usr/libexec/qemu-kvm -M q35 \

-m 4G -cpu Opteron_G3,check -smp 4,sockets=4,cores=1,threads=1,maxcpus=4 -enable-kvm -spice port=5931,disable-ticketing -monitor stdio -qmp tcp:0:6666,server,nowait -boot menu=on,reboot-timeout=8,strict=on \

-device ich9-usb-ehci1,id=usb,bus=pcie.0,addr=0x5.0x7 -device ich9-usb-uhci1,masterbus=usb.0,firstport=0,bus=pcie.0,multifunction=on,addr=0x5 -device ich9-usb-uhci2,masterbus=usb.0,firstport=2,bus=pcie.0,addr=0x5.0x1 -device ich9-usb-uhci3,masterbus=usb.0,firstport=4,bus=pcie.0,addr=0x5.0x2 \

-drive file=/home/,RHEL-Server-7.2-64-virtio-scsi.qcow2if=none,id=drive-data-disk1,cache=writethrough,format=qcow2,werror=stop,rerror=stop -device usb-storage,drive=drive-data-disk1,id=usb-0-0,removable=on
2.check the mouse in guest
3.

Actual results:
The mouse in guest disappears, but after opening an application(e.g. terminal)  the mouse could appear.

Expected results:
The mouse does not disappear. 

Additional info:

Comment 2 Gerd Hoffmann 2015-07-07 07:37:53 UTC
Guest bug.  modesetting driver most likely.  Saw that with fedora guests too.  Cursor isn't there initially, but shows up on the first shape change (when moving over the gdm password field for example).

Note: qemu stdvga has no hardware cursor support, might be the trigger for this bug.

Comment 3 Adam Jackson 2015-07-15 20:27:07 UTC
Reassign to xorg-x11-server, which has replaced -modesetting in 7.2.

Comment 4 Adam Jackson 2015-07-22 16:15:21 UTC
7.2 modesetting driver needs patches merged from the old packaging, devel ack.

Comment 8 errata-xmlrpc 2015-11-19 04:27:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2198.html