Bug 1238168

Summary: FTBFS: Failed during 'make check': 13netlink-message-attrs.t and 20io-socket-netlink-generic.t
Product: [Fedora] Fedora Reporter: Karsten Hopp <karsten>
Component: perl-Socket-NetlinkAssignee: Petr Pisar <ppisar>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 23CC: emmanuel, perl-devel, ppisar
Target Milestone: ---   
Target Release: ---   
Hardware: ppc64   
OS: Linux   
Whiteboard:
Fixed In Version: perl-Socket-Netlink-0.04-17.fc26 perl-Socket-Netlink-0.04-16.fc23 perl-Socket-Netlink-0.04-16.fc24 perl-Socket-Netlink-0.04-17.fc25 perl-Socket-Netlink-0.04-3.el6 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-11-19 07:25:24 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1071880    

Description Karsten Hopp 2015-07-01 10:38:17 UTC
Description of problem:
A build of perl-Socket-Netlink-0.04-14.fc23 on ppc64 (big-endian) failed at the 'make check' stage:

t/11netlink-message.t ............... ok
t/12netlink-message-header.t ........ ok
#   Failed test '$message->attrs after unpack'
#   at t/13netlink-message-attrs.t line 98.
#     Structures begin differing at:
#          $got->{str} = ''
#     $expected->{str} = 'FGH'
# Looks like you failed 1 test of 14.
t/13netlink-message-attrs.t ......... 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/14 subtests 
t/14netlink-message-error.t ......... ok
t/15netlink-message-typesubclass.t .. ok
#   Failed test '$message->pack'
#   at t/20io-socket-netlink-generic.t line 55.
#   at bytes 0-0xf (0-15)
#   got: | 00 00 00 14 00 1e 00 00 00 00 00 00 00 00 00 00 |................|
#   exp: | 00 00 00 14 00 00 00 1e 00 00 00 00 00 00 00 00 |................|
# Looks like you failed 1 test of 13.
t/20io-socket-netlink-generic.t ..... 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/13 subtests 
t/99pod.t ........................... skipped: Test::Pod 1.00 required for testing POD
Test Summary Report
-------------------
t/13netlink-message-attrs.t       (Wstat: 256 Tests: 14 Failed: 1)
  Failed test:  11
  Non-zero exit status: 1
t/20io-socket-netlink-generic.t   (Wstat: 256 Tests: 13 Failed: 1)
  Failed test:  12
  Non-zero exit status: 1
Files=11, Tests=77,  1 wallclock secs ( 0.06 usr  0.01 sys +  0.56 cusr  0.05 csys =  0.68 CPU)
Result: FAIL
Failed 2/11 test programs. 2/77 subtests failed.

Version-Release number of selected component (if applicable):
perl-Socket-Netlink-0.04-14.fc23

How reproducible:
always

Steps to Reproduce:
1. ppc-koji build --scratch f23 perl-Socket-Netlink-0.04-14.fc23.src.rpm
2.
3.

Actual results:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=2609707

Comment 1 Petr Pisar 2016-11-09 08:26:37 UTC
Big-endian PowerPC is now a fully supported Fedora architecture and current perl-Socket-Netlink-0.04-16.fc26 still fails.

Comment 2 Petr Pisar 2016-11-09 12:42:56 UTC
I developed the fix. I will apply it together with other fixes.

Comment 3 Fedora Update System 2016-11-09 13:24:26 UTC
perl-Socket-Netlink-0.04-17.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-516414cec8

Comment 4 Fedora Update System 2016-11-09 13:24:35 UTC
perl-Socket-Netlink-0.04-16.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8f0ac6afe1

Comment 5 Fedora Update System 2016-11-09 13:24:52 UTC
perl-Socket-Netlink-0.04-16.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-2493087a3e

Comment 6 Petr Pisar 2016-11-09 13:32:19 UTC
*** Bug 808197 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2016-11-09 13:33:01 UTC
perl-Socket-Netlink-0.04-3.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-5300747e76

Comment 8 Fedora Update System 2016-11-10 04:51:22 UTC
perl-Socket-Netlink-0.04-16.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-2493087a3e

Comment 9 Fedora Update System 2016-11-10 04:58:50 UTC
perl-Socket-Netlink-0.04-16.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8f0ac6afe1

Comment 10 Fedora Update System 2016-11-10 06:47:58 UTC
perl-Socket-Netlink-0.04-3.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-5300747e76

Comment 11 Fedora Update System 2016-11-10 19:26:05 UTC
perl-Socket-Netlink-0.04-17.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-516414cec8

Comment 12 Fedora Update System 2016-11-19 07:25:24 UTC
perl-Socket-Netlink-0.04-16.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2016-11-19 17:23:54 UTC
perl-Socket-Netlink-0.04-16.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2016-11-19 21:14:59 UTC
perl-Socket-Netlink-0.04-17.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2016-11-24 23:46:47 UTC
perl-Socket-Netlink-0.04-3.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.