Bug 1247216

Summary: Tor fails to start at boot
Product: [Fedora] Fedora Reporter: ByteEnable
Component: torAssignee: Nobody's working on this, feel free to take it <nobody>
Status: CLOSED EOL QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 22CC: jorti, jth, lmacken, pwouters, s
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-07-19 17:12:43 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description ByteEnable 2015-07-27 14:52:12 UTC
Description of problem:
I have configured tor as a bridge relay, and when I boot my computer, it fails to start automatically. This is what I see:

# systemctl status tor.service
● tor.service - Anonymizing overlay network for TCP
   Loaded: loaded (/usr/lib/systemd/system/tor.service; enabled; vendor preset: disabled)
   Active: failed (Result: start-limit) since Mon 2015-07-27 08:55:20 CDT; 6min ago
 Main PID: 3241 (code=exited, status=1/FAILURE)

Jul 27 08:55:20 systemd[1]: Unit tor.service entered failed state.
Jul 27 08:55:20 systemd[1]: tor.service failed.
Jul 27 08:55:20 systemd[1]: tor.service holdoff time over, sched...t.
Jul 27 08:55:20 systemd[1]: start request repeated too quickly f...ce
Jul 27 08:55:20 systemd[1]: Failed to start Anonymizing overlay ...P.
Jul 27 08:55:20 systemd[1]: Unit tor.service entered failed state.
Jul 27 08:55:20 systemd[1]: tor.service failed.
Hint: Some lines were ellipsized, use -l to show in full.


Version-Release number of selected component (if applicable):

tor-0.2.6.10-1.fc22.x86_64

How reproducible:
In my system, when I reboot, it doesn't start

Steps to Reproduce:
1. systemctl enable tor.service
2. reboot
3. systemctl status tor.service

Actual results:
Tor doesn't start

Expected results:
Tor has started

Permissions in /var/lib/tor was the issue per this closed bug:

https://bugzilla.redhat.com/show_bug.cgi?id=974477#c11

Tor was running fine until the update.

Comment 1 Joergen Thomsen 2015-10-28 16:09:32 UTC
/etc/tor/torrc for some reason must be other readable (chmod o+r /etc/tor/torrc)

Comment 2 Juan Orti Alcaine 2016-03-15 07:36:06 UTC
In my case it was I have a IPv6 ORPort and it couldn't bind to that address at startup, I had to do:

# systemctl enable NetworkManager-wait-online.service
# systemctl edit tor.service

[Unit]
After=network-online.target
Requires=network-online.target

Comment 3 Fedora End Of Life 2016-07-19 17:12:43 UTC
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.