Bug 1250675

Summary: please build golang-googlecode-go-crypto for epel7
Product: [Fedora] Fedora EPEL Reporter: Carl George <carl>
Component: golang-googlecode-go-cryptoAssignee: FridolĂ­n PokornĂ˝ <fpokorny>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: epel7CC: carl, fpokorny, golang-updates, jchaloup, redhat-bugzilla, vbatts
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-07-14 13:40:14 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1332664, 1250094    

Description Carl George 2015-08-05 18:30:12 UTC
Description of problem:

I would like to see asciinema in epel7.  The latest version requires this go package.  Please build it for epel7.

Comment 1 Jan Chaloupka 2015-08-06 10:54:57 UTC
Hi Carl,

what version of asciinema would you like? Running scan on version 1.1.1 I get:

asciinema-1.1.1]$ gofed ggi --show-occurrence --all-occurrences | sed "s/github.com\/asciinema\/asciinema\/Godeps\/_workspace\/src\///"
	code.google.com/p/gcfg                   (util/cfg.go:util)
	code.google.com/p/go.crypto/ssh/terminal (terminal/terminal.go:terminal)
	github.com/creack/termios/raw            (terminal/terminal.go:terminal)
	github.com/docopt/docopt-go              (main.go:main)
	github.com/kr/pty                        (terminal/terminal.go:terminal)

github.com/kr/pty has no epel7 branch either, github.com/creack/termios/raw is not packaged in Fedora at all.

Can you create a new bug for building asciinema for epel7 and reference both 1250674, 1250675 in it as blocking bugs? So it is easier to track all updated and requests. Thank you

Have you discussed asciinema for epel7 with Jakub [1]? He is the maintainer.

[1] https://admin.fedoraproject.org/pkgdb/packager/kubo/

Comment 2 Jan Chaloupka 2015-08-06 10:56:04 UTC
I see, here https://bugzilla.redhat.com/show_bug.cgi?id=1250094 :)

Comment 3 Carl George 2015-08-10 15:33:07 UTC
Howdy Jan,

Might as well do the latest upstream release of asciinema.

"github.com/kr/pty" is not in EPEL7 because it is in EL7 base.

https://git.centos.org/summary/!!!!rpms!golang-github-kr-pty.git

I wasn't aware of the termios dependency.  I'm not as familiar with go as I would like to be.  Is that something you are interested in submitting/maintaining for Fedora and EPEL?

Comment 4 Robert Scheck 2016-05-03 11:26:01 UTC
Where exactly is this stuck? I rebuilt golang-googlecode-go-crypto from Fedora
Rawhide against EPEL 7 locally now.

Comment 5 Carl George 2016-07-14 13:40:14 UTC
This is no longer needed, asciinema switched back to Python.