Bug 1258031

Summary: [RFE] Short lived URL based access to protected content (download selected pkgs from UI)
Product: Red Hat Satellite Reporter: Bryan Kearney <bkearney>
Component: PulpAssignee: satellite6-bugs <satellite6-bugs>
Status: CLOSED WONTFIX QA Contact: Katello QA List <katello-qa-list>
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1.0CC: bmbouter, daniele, daviddavis, dkliban, ggainey, ipanova, jsherril, mhrivnak, pcreech, rchan, ttereshc
Target Milestone: UnspecifiedKeywords: FutureFeature, Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Cause: Consequence: Fix: Result:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-14 18:03:05 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Bryan Kearney 2015-08-28 17:28:09 UTC
The katello UI would like to support the ability for a user from the UI or the CLI to download specific packages. Since these packages may be protected by certificates, there needs to be a way for teh UI to create a url which bypasses this. 

Apache mod_auth_token is one such tool for this type of access. This RFE is for pulp to support a means for katello to create short lived access which bypasses certificate checks and allows direct download.

-- bk

Comment 1 Justin Sherrill 2015-08-28 17:43:49 UTC
Another feature sat5 had was the ability to select multiple packages and download them all in a zip file.




Also we probably want the ability to download puppet modules and other types of content.

Comment 4 Bryan Kearney 2015-10-15 18:18:21 UTC
Upstream Pulp Request https://pulp.plan.io/issues/1315

Comment 5 Brad Buckingham 2016-11-21 18:27:14 UTC
Created redmine issue http://projects.theforeman.org/issues/17429 from this bug

Comment 6 pulp-infra@redhat.com 2016-11-21 18:56:09 UTC
The Pulp upstream bug status is at NEW. Updating the external tracker on this bug.

Comment 7 pulp-infra@redhat.com 2016-11-21 18:56:12 UTC
The Pulp upstream bug priority is at Normal. Updating the external tracker on this bug.

Comment 9 Bryan Kearney 2018-06-14 18:03:05 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in product in the forseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.

Comment 10 pulp-infra@redhat.com 2019-06-27 13:11:42 UTC
The Pulp upstream bug status is at CLOSED - WONTFIX. Updating the external tracker on this bug.