Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.

Bug 1260000

Summary: handling of "No original_tombstone for changenumber" errors
Product: Red Hat Enterprise Linux 7 Reporter: Jan Kurik <jkurik>
Component: 389-ds-baseAssignee: Noriko Hosoi <nhosoi>
Status: CLOSED ERRATA QA Contact: Viktor Ashirov <vashirov>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 7.1CC: ekeck, mnavrati, msauton, nhosoi, nkinder, rmeggins, sramling
Target Milestone: rcKeywords: ZStream
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: 389-ds-base-1.3.3.1-21.el7_1 Doc Type: Bug Fix
Doc Text:
Prior to this update, the "No original_tombstone for changenumber" error message was logged unnecessarily when original_tombstone did not exist. As a consequence, the error log contained redundant entries. Now, the error message is logged only when needed.
Story Points: ---
Clone Of: 1235847 Environment:
Last Closed: 2015-11-03 03:21:13 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 1235847    
Bug Blocks:    

Description Jan Kurik 2015-09-04 02:56:43 EDT
This bug has been copied from bug #1235847 and has been proposed
to be backported to 7.1 z-stream (EUS).
Comment 5 Sankar Ramalingam 2015-10-05 07:51:53 EDT
[root@dell-per905-01 MMR_WINSYNC]# PORT="1289"; ldapsearch -x -p $PORT -h localhost -D "cn=Directory Manager" -w Secret123 -b "cn=replica,cn=\"dc=passsync,dc=com\",cn=mapping tree,cn=config"  nsds5ReplicaPurgeDelay nsds5ReplicaTombstonePurgeInterval |grep -i nsds5Replica
# requesting: nsds5ReplicaPurgeDelay nsds5ReplicaTombstonePurgeInterval 
nsds5ReplicaPurgeDelay: 120
nsds5ReplicaTombstonePurgeInterval: 90

[root@dell-per905-01 MMR_WINSYNC]# PORT="1189"; ldapsearch -x -p $PORT -h localhost -D "cn=Directory Manager" -w Secret123 -b "cn=replica,cn=\"dc=passsync,dc=com\",cn=mapping tree,cn=config"  nsds5ReplicaPurgeDelay nsds5ReplicaTombstonePurgeInterval |grep -i nsds5Replica
# requesting: nsds5ReplicaPurgeDelay nsds5ReplicaTombstonePurgeInterval 
nsds5ReplicaPurgeDelay: 120
nsds5ReplicaTombstonePurgeInterval: 90

After setting the values for nsds5ReplicaPurgeDelay and nsds5ReplicaTombstonePurgeInterval, added/deleted few thousands of entries.

Then, checked if there are any errors related to tombstone.

[root@dell-per905-01 MMR_WINSYNC]# grep -i "No original_tombstone for changenumber" /var/log/dirsrv/slapd-M1/*
[root@dell-per905-01 MMR_WINSYNC]# grep -i "No original_tombstone for changenumber" /var/log/dirsrv/slapd-M2/*


No error messages in the error logs as mentioned in https://bugzilla.redhat.com/show_bug.cgi?id=1235847#c5.

Hence, marking the bug as verified.

Build tested:
[root@dell-per905-01 MMR_WINSYNC]# rpm -qa |grep -i 389-ds
389-ds-base-libs-1.3.3.1-23.el7_1.x86_64
389-ds-base-1.3.3.1-23.el7_1.x86_64
389-ds-base-debuginfo-1.3.3.1-23.el7_1.x86_64
Comment 7 errata-xmlrpc 2015-11-03 03:21:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1960.html