Bug 1261891

Summary: [RFE] Enable LDAP authentication support in RHCS
Product: Red Hat Ceph Storage Reporter: Vimal Kumar <vikumar>
Component: RGWAssignee: Matt Benjamin (redhat) <mbenjamin>
Status: CLOSED ERRATA QA Contact: shylesh <shmohan>
Severity: medium Docs Contact: Bara Ancincova <bancinco>
Priority: medium    
Version: 1.3.0CC: cbodley, ceph-eng-bugs, hnallurv, icolle, kbader, kdreyer, mbenjamin, mwatts, nlevine, owasserm, sweil, vumrao, yweinste
Target Milestone: rcKeywords: FutureFeature, Triaged
Target Release: 2.0   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
.Active Directory/LDAP authentication is now supported Red Hat Ceph Storage now supports LDAP authentication. As a result, users can use LDAP accounts to access buckets in the Ceph Object Gateway. In addition, they can use LDAP authentication to authenticate against Microsoft Active Directory. For details see the https://access.redhat.com/documentation/en/red-hat-ceph-storage/2/single/ceph-object-gateway-with-ldap-ad-guide/[Ceph Object Gateway with LDAP/AD] guide.
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-08-23 19:26:07 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1322504    

Comment 10 shylesh 2016-08-04 15:06:00 UTC
Tested this feature with redhat-ds-10.0.0-1.el7dsrv.x86_64 on both ubuntu and RHEL as clients. All the planned tests are complete , hence marking this as verified.

Comment 13 errata-xmlrpc 2016-08-23 19:26:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1755