Bug 1262393 (CVE-2015-6908)

Summary: CVE-2015-6908 openldap: ber_get_next denial of service vulnerability
Product: [Other] Security Response Reporter: Martin Prpič <mprpic>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED ERRATA QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: unspecifiedCC: carnil, ebenes, jplans, jsynacek, jv+fedora, mhonek, phracek, pkis, rmeggins, scorneli, slong, totszwai, vashirov
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: impact=important,public=20150909,reported=20150911,source=oss-security,cvss2=5.0/AV:N/AC:L/Au:N/C:N/I:N/A:P,cwe=CWE-20,fedora-all/openldap=affected,rhel-4/openldap=wontfix,rhel-5/openldap=affected,rhel-6/openldap=affected,rhel-7/openldap=affected
Fixed In Version: Doc Type: Bug Fix
Doc Text:
A flaw was found in the way the OpenLDAP server daemon (slapd) parsed certain Basic Encoding Rules (BER) data. A remote attacker could use this flaw to crash slapd via a specially crafted packet.
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-09-29 10:33:06 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 1262396, 1263170, 1263171, 1263172, 1263173, 1263174    
Bug Blocks: 1262395    

Description Martin Prpič 2015-09-11 14:20:30 UTC
A flaw was found in the way the OpenLDAP server daemon (slapd) parsed certain BER data. A remote attacker could use this flaw to crash slapd via a specially crafted packet.

Upstream advisory (including a reproducer):

http://www.openldap.org/its/index.cgi/Software%20Bugs?id=8240

Upstream patch:

http://www.openldap.org/devel/gitweb.cgi?p=openldap.git;a=commitdiff;h=6fe51a9ab04fd28bbc171da3cf12f1c1040d6629

CVE assignment request:

http://seclists.org/oss-sec/2015/q3/535

Comment 1 Martin Prpič 2015-09-11 14:22:07 UTC
Created openldap tracking bugs for this issue:

Affects: fedora-all [bug 1262396]

Comment 4 errata-xmlrpc 2015-09-29 10:21:32 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7
  Red Hat Enterprise Linux 6
  Red Hat Enterprise Linux 5

Via RHSA-2015:1840 https://rhn.redhat.com/errata/RHSA-2015-1840.html