Bug 1265922

Summary: amavisd and clamav dependencies
Product: [Fedora] Fedora EPEL Reporter: Marco Favero <sistemisti-posta>
Component: amavisd-newAssignee: Juan Orti <jorti>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: epel7CC: janfrode, jorti, perl-devel, ppisar, steve, vanmeeuwen+fedora
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: amavisd-new-2.10.1-5.el7 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-12-12 19:23:30 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1275630    
Bug Blocks:    

Description Marco Favero 2015-09-24 07:31:20 UTC
Description of problem:

I have amavisd-new without local clamd server, because I configured it remotely through instream protocol.
I very appreciate if you could leave clamav and altermime dependencies.

Version-Release number of selected component (if applicable):

amavisd-new-2.10.1-4.el7

Now I forcedly removed clamav, but it is not good: 
** Found 3 pre-existing rpmdb problem(s), 'yum check' output follows:
amavisd-new-2.10.1-4.el7.noarch has missing requires of altermime
amavisd-new-2.10.1-4.el7.noarch has missing requires of clamav-server
amavisd-new-2.10.1-4.el7.noarch has missing requires of clamav-server-systemd

Thanks a lot

Comment 1 Juan Orti 2015-09-24 08:03:41 UTC
Couldn't you just simply mask the clamd service? It is used in the default config.

# systemctl mask clamd@amavisd.service

And why you want to drop altermime? it is used by amavisd-new.

Comment 2 Marco Favero 2015-09-24 10:44:21 UTC
(In reply to Juan Orti from comment #1)
> Couldn't you just simply mask the clamd service? It is used in the default
> config.
> 
> # systemctl mask clamd@amavisd.service
> 
> And why you want to drop altermime? it is used by amavisd-new.

Ok, I can use this method and keep altermime. Thank you.

I would like to avoid to install clamav server because it is not mandatory on the same host of Amavis. If I don't install a not required clamav server I prevent confusion on administration.

Comment 3 Juan Orti 2015-10-27 09:59:52 UTC
I need the clamav-server dependency because amavisd-new install files in /etc/clamd.d/

Comment 4 Marco Favero 2015-10-27 10:58:13 UTC
Ok, anyway clamd is not a dependency on the same host for Amavis.
Clamd can be configured in STREAM protocol:

   ['ClamAV-clamd-stream',
    \&ask_daemon, ["*", 'clamd:clam.example.org:3310'],
     qr/\bOK$/m, qr/\bFOUND$/m,
     qr/^.*?: (?!Infected Archive)(.*) FOUND$/m ],

Regards

Comment 5 Petr Pisar 2015-10-27 11:21:29 UTC
If the only reason for the dependency is the directory ownership, you can co-own the directory instead of having the dependency.

Comment 6 Juan Orti 2015-10-27 11:52:54 UTC
Ok, I see there is a clamav-filesystem package but it doesn't own the directory. I have opened a bug to move the ownership of the directory to that package and then I'll depend on it to avoid installing the full server.

Comment 7 Fedora Update System 2015-11-23 21:49:01 UTC
amavisd-new-2.10.1-5.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-501bd58eaf

Comment 8 Fedora Update System 2015-11-26 00:54:32 UTC
amavisd-new-2.10.1-5.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update amavisd-new'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-501bd58eaf

Comment 9 Fedora Update System 2015-12-12 19:23:26 UTC
amavisd-new-2.10.1-5.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.