Bug 1269

Summary: startx dies with font error until xfs is restarted
Product: [Retired] Red Hat Linux Reporter: Chris Runge <crunge>
Component: XFree86Assignee: Cristian Gafton <gafton>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-03-19 00:33:22 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Chris Runge 1999-02-21 19:45:29 UTC
RHL 5.8.1 (Beta 1)

Upgraded 5.8 to 5.8.1, created a normal user, logged in as
that user, and typed startx.  This error appeared:


_FontTransSocketINETConnect: Can't connect: errno = 111
failed to set default font path 'tcp/localhost:7100'
Fatal server error:
could not open default font 'fixed'

When reporting a problem related to a server crash, please
send the full server output, not just the last messages

X connection to :0.0 broken (explicit kill or server
shutdown).


as root I did this:
/etc/rc.d/init.d/xfs restart


I can then do a startx again and it works fine.

NOTE: this happened immediately after the upgrade and after
a reboot (perhaps xfs is not initializing properly upon
boot?)

Comment 1 Cristian Gafton 1999-03-19 00:33:59 UTC
xfs was not starting by default on boot. Should be fixed now in the
beta release.

Comment 2 Matthew Miller 2000-04-19 00:37:59 UTC
I'm still seeing this occasionally on 6.2 final systems. (Fresh installs.) I
can't figure it out or make it reproducable, unfortunately, but this IS still a
problem. :(