Bug 1270279

Summary: AAVMF: output improvements
Product: Red Hat Enterprise Linux 7 Reporter: Andrew Jones <drjones>
Component: OVMFAssignee: Laszlo Ersek <lersek>
Status: CLOSED CURRENTRELEASE QA Contact: Virtualization Bugs <virt-bugs>
Severity: unspecified Docs Contact: Jiri Herrmann <jherrman>
Priority: unspecified    
Version: 7.1CC: chayang, juzhang, lmiksik, michen, mrezanin, qizhu
Target Milestone: rcKeywords: OtherQA, Rebase
Target Release: ---   
Hardware: aarch64   
OS: Unspecified   
Whiteboard:
Fixed In Version: ovmf-20151104-1.gitb9ffeab.el7 Doc Type: No Doc Update
Doc Text:
no doc update
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-10-10 06:58:37 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Andrew Jones 2015-10-09 09:32:45 EDT
Two suggestions for output improvements

1) When creating a brand new guest there's typically no nvram yet. AAVMF reports this as an error, but then corrects it and moves on fine. I.e.

ValidateFvHeader: Variable Store Guid non-compatible
NorFlashFvbInitialize: ERROR - The FVB Header is not valid. Installing a correct one for this volume.
Ftw: Work block header check error
Ftw: Work block header check error
Ftw: Both are invalid, init workspace

Status messages that don't say "error" might be nicer, as this is standard new guest behavior.

2) I once requested quieting AAVMF's output messages, so we now have the default (quiet) and also a verbose version that can be used. Now I'd like to suggest that the quiet one output at least one message though, something like "Starting UEFI...", because currently several seconds go by with no output - long enough to start suspecting a hang.
Comment 4 Laszlo Ersek 2015-10-13 08:03:24 EDT
I posted a patch set

[edk2] [PATCH 0/3] soften some (non-)ERROR messages
http://thread.gmane.org/gmane.comp.bios.edk2.devel/2902

that should take care of the annoying messages in the current state of upstream.

With regard to the "Starting UEFI..." message, to be printed early in SEC, I think we should do that in downstream only.
Comment 5 Laszlo Ersek 2015-10-13 11:50:11 EDT
Based on further discussion, I'll try to log a "Starting UEFI..."-like message in upstream too, on DEBUG_INFO level, and in downstream we could flip that to DEBUG_ERROR.
Comment 6 Laszlo Ersek 2015-10-14 08:31:52 EDT
Posted v2:
http://thread.gmane.org/gmane.comp.bios.edk2.devel/2996
Comment 7 Laszlo Ersek 2015-10-26 10:24:49 EDT
The first four patches of v2 have been committed.

The second half seems to be generally ignored, so we should carry those three of said four patches that we actually need in downstream only.
Comment 13 Laszlo Ersek 2017-10-10 06:58:37 EDT
Fixed in RHEL-ALT-7.3.