Bug 1270398

Summary: recommends for packages causes issues[solution]
Product: [Fedora] Fedora Reporter: Richard Jasmin <spike85051>
Component: dnfAssignee: Packaging Maintenance Team <packaging-team-maint>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 22CC: jsilhan, mluscon, packaging-team-maint, pnemade, vmukhame
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-10-13 14:42:26 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Richard Jasmin 2015-10-09 22:02:14 UTC
Description of problem:
This is a solution to a dnf bug. Either something changed recommends into required depends for 22+ -or- dnf is misreading them.

for instance:
qt chudman wants to install mame but does not actually depend on it. (chudman) chdman only needs itself to convert files. but chudman itself may be shoved into mame packages because its not there prior to installing qt chudman.I would think chudman would be a seperate package. its a utility, you dont need mame for it.

Do note that this happens for other apps like keepass as well.Althought keepass depends on mono, mono and keepass are seperate entities. removing keepass(for whatever reason, in my instance the web release was newer) should not remove mono.

I think somewhere along the line recommends got changed into requires.And reverse depends like this should not occur.

Version-Release number of selected component (if applicable):
22+

How reproducible:
install an app with recommends or depends

Comment 1 Michal Luscon 2015-10-13 14:42:26 UTC
I think this is a consequence of clean_requirements_on_remove=True. You can mark packages as userinstalled by "dnf mark install <package>". Feel free to reopen if it does not help.

dnf.readthedocs.org/en/latest/conf_ref.html#clean-requirements-on-remove-label