Bug 127234

Summary: ls --format=vertical generates garbage output
Product: [Fedora] Fedora Reporter: David Favro <dfavro>
Component: coreutilsAssignee: Tim Waugh <twaugh>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 2   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 14:04:20 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description David Favro 2004-07-04 21:38:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1) Opera 
7.50  [en]

Description of problem:
The --format=vertical option seems to me to be broken: it is 
documented to be the same as -C, but in addition to not producing the 
same output, it produces seemingly erroneous output.  I reported the 
bug, as instructed by the 'ls' command, to GNU, who suggested that I 
recompile the virgin source: I did so and that fixed the bug.  The 
erroneous output is documented in the e-mails included below:

===============================================================

Date: Sat, 03 Jul 2004 13:59:55 -0400
To: bug-coreutils@gnu.org
Subject: ls bug?
From: "David Favro" <dfavro@users.sourceforge.net>

Dear sirs:
 
I am running FSF ls version 5.2.1 on Fedora Core 2 (i.e. Linux 
distribution) -- it is the binary version of ls that was distributed 
with the Fedora Core 2 Linux distribution.  The --format=vertical 
option seems to me to be broken: it is documented to be the same as 
-C, but in addition to not producing the same output, it produces 
seemingly erroneous output (output shown below).
 
Thank you for your fine work,
David Favro
Meta-Dynamic Solutions, LLC
dfavro@users.sourceforge.net
 
/etc/rc.d % ls --version
ls (coreutils) 5.2.1
Written by Richard Stallman and David MacKenzie.

Copyright (C) 2004 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There 
is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A 
PARTICULAR PURPOSE.
/etc/rc.d % ls -C
init.d  rc  rc0.d  rc1.d  rc2.d  rc3.d  rc4.d  rc5.d  rc6.d  rc.local 
 rc.sysinit
/etc/rc.d % ls --format=vertical
(null)                           init.d
(null)                           rc
(null)                           rc0.d
(null)                           rc1.d
(null)                           rc2.d
(null)                           rc3.d
(null)                           rc4.d
(null)                           rc5.d
(null)                           rc6.d
(null)                           rc.local
(null)                           rc.sysinit
/etc/rc.d %

===============================================================

To: "David Favro" <dfavro@users.sourceforge.net>
Cc: bug-coreutils@gnu.org
Subject: Re: ls bug?
Date: Mon, 05 Jul 2004 00:19:12 +0200

[...]

Thanks for the report.
Would you please see if you can reproduce the problem
using ls built from these unmodified sources?

  ftp://ftp.gnu.org/gnu/coreutils/coreutils-5.2.1.tar.gz
  ftp://ftp.gnu.org/gnu/coreutils/coreutils-5.2.1.tar.bz2

I'm pretty sure the version that comes with RH/Fedora includes
significant patches.

===============================================================

Date: Sun, 04 Jul 2004 20:27:36 -0400
Subject: Re: ls bug?
From: "David Favro" <dfavro@users.sourceforge.net>

[...]

You are right, that fixed it.  I hadn't tried building it since 
Fedora's version number matched the latest from your source, and it 
seems unusual for an O/S distribution to make mods to such a 
"generic" utility.  I guess I'll report it to Fedora.  Thanks again.
 
--
David Favro
Meta-Dynamic Solutions, LLC
dfavro@users.sourceforge.net



Version-Release number of selected component (if applicable):
coreutils-5.2.1-7

How reproducible:
Always

Steps to Reproduce:
1. Use 'ls --format=vertical' in any directory containing more than 2 
files.


Actual Results:  See bug description


Expected Results:  Identical to 'ls -C'


Additional info:
Comment 1 Tim Waugh 2004-07-05 05:15:04 EDT
Thanks.  This has already been reported and the fixed package is in
the current Fedora development tree.

*** This bug has been marked as a duplicate of 125238 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:04:20 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.