Bug 1272587

Summary: Fix cluster schema (/cluster/rm/resources/action is wrong)
Product: Red Hat Enterprise Linux 6 Reporter: Jan Pokorný [poki] <jpokorny>
Component: resource-agentsAssignee: Jan Pokorný [poki] <jpokorny>
Status: CLOSED ERRATA QA Contact: cluster-qe <cluster-qe>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 6.5CC: agk, ccaulfie, cfeist, cluster-maint, cluster-qe, fdinitto, jkortus, jpokorny, rpeterso, rsteiger, teigland
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: resource-agents-3.9.5-31.el6 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1044048
: 1272588 (view as bug list) Environment:
Last Closed: 2016-05-10 19:15:02 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1173942    
Bug Blocks: 1272588    

Description Jan Pokorný [poki] 2015-10-16 19:42:11 UTC
+++ This bug was initially created as a clone of Bug #1044048 +++

--- Additional comment from Jan Pokorný on 2014-12-16 16:44:40 CET ---

Another discovery (thanks to Piyush Sharma):

/cluster/rm/resources/action -> wrong
/cluster/rm/resources/SOMETHING/action -> ok (for SOMETHING in clusterfs, ip, ...)

As a side effect, wrongly-alleged-valid first case is what makes luci
choke: [bug 1173942].

--- Additional comment from Jan Pokorný on 2014-12-16 18:03:15 CET ---

...as per rgmanager's code examination

--- Additional comment from Jan Pokorný on 2015-10-16 21:37:02 CEST ---

Definitely 6.8 material.

Comment 8 errata-xmlrpc 2016-05-10 19:15:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0735.html

Comment 9 Jan Pokorný [poki] 2016-11-11 14:31:03 UTC
Forgotten, but eventually delivered upstream fix:
https://github.com/ClusterLabs/resource-agents/pull/879