Bug 1274726 (CVE-2015-7884)

Summary: CVE-2015-7884 kernel: media/vivid-osd: information leak in ioctl
Product: [Other] Security Response Reporter: Martin Prpič <mprpic>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED NOTABUG QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: unspecifiedCC: agordeev, aquini, arm-mgr, bhu, dhoward, esammons, fhrbata, gansalmon, iboverma, itamar, jforbes, jkacur, joelsmith, jonathan, jross, jwboyer, kernel-maint, kernel-mgr, kstutsma, lgoncalv, lwang, madhu.chinakonda, matt, mchehab, mcressma, mguzik, nmurray, pholasek, plougher, rt-maint, rvrbovsk, vdronov, williams, wmealing
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-01-26 13:54:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1274730    
Bug Blocks: 1274735    

Description Martin Prpič 2015-10-23 13:01:07 UTC
An information leak flaw was found in Linux kernel for systems using Vivid! display drivers in framebuffer mode.  16 bytes of memory is not zeroed and may leak from userspace to a user at the console.

Original report:

http://seclists.org/oss-sec/2015/q4/115

Upstream patch:

http://git.kernel.org/cgit/linux/kernel/git/next/linux-next.git/commit/?id=eda98796aff0d9bf41094b06811f5def3b4c333c

Comment 1 Martin Prpič 2015-10-23 13:03:52 UTC
Created kernel tracking bugs for this issue:

Affects: fedora-all [bug 1274730]

Comment 2 Josh Boyer 2015-10-23 13:25:05 UTC
This requires CONFIG_VIDEO_VIVID to be enabled.  None of the Fedora kernels have this driver enabled.

Comment 4 Vladis Dronov 2016-01-26 13:54:38 UTC
Statement:

This issue does not affect the Linux kernel packages as shipped with Red Hat Enterprise Linux 5, 6, 7 and MRG-2 as the code with the flaw is not present in the products listed.