Bug 1278467

Summary: Not able to upgrade hypervisor using Ovirt engine api
Product: Red Hat Enterprise Virtualization Manager Reporter: nijin ashok <nashok>
Component: ovirt-engineAssignee: Moti Asayag <masayag>
Status: CLOSED ERRATA QA Contact: Pavol Brilla <pbrilla>
Severity: medium Docs Contact:
Priority: medium    
Version: 3.5.4CC: bazulay, gklein, juan.hernandez, lsurette, masayag, mgoldboi, oourfali, pstehlik, rbalakri, Rhev-m-bugs, yeylon, ykaul
Target Milestone: ovirt-3.6.1Keywords: Regression, ZStream
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1279461 (view as bug list) Environment:
Last Closed: 2016-03-09 21:14:16 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Infra RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1279461    

Description nijin ashok 2015-11-05 14:45:15 UTC
Description of problem:

In RHEV-M 3.5.x it's not able to upgrade the hypervisor through api.  I have tried with

curl -X POST -H  "Content-type: application/xml" -u admin@internal:mypass
 --insecure -d "<action><root_password>mypass</root_password><image>rhevh-latest-6.iso</image></action>" https://172.16.1.1/ovirt-engine/api/hosts/f6c26927-b91b-4000-8e3a-e6abaa1c23c5/install/

Seems it is triggering only the "InstallVdsInternalCommand" according to
the engine logs. It is just doing the  reinitialization of the hypervisor
which is  same as that of we use the "Reinstall" option from the RHEV
Manager. It doesn't seems to be detecting or transferring the iso image from
the Manager to the hypervisor.

When we use the "upgrade" from the RHEV Manager GUI I can see that the
UpgradeOvirtNodeInternalCommand is triggered in the engine logs.

The above command is working in 3.4, but not in 3.5 . The one difference I can see between 3.4 and 3.5 is that in 3.5 we have two option in GUI to upgrade and reinstall which initiate  InstallVdsInternalCommand and  UpgradeOvirtNodeInternalCommand respectively. But in 3.4 it has only one option which always initiate InstallVdsInternalCommand.

I can see /upgrade option in the upstream ovirt 3.6.

Version-Release number of selected component (if applicable):

Red Hat Enterprise Virtualization 3.5

How reproducible:

100%

Steps to Reproduce:

1. Try to upgrade a host using the command

curl -X POST -H  "Content-type: application/xml" -u admin@internal:mypass
 --insecure -d "<action><root_password>mypass</root_password><image>rhevh-latest-6.iso</image></action>" https://172.16.1.1/ovirt-engine/api/hosts/f6c26927-b91b-4000-8e3a-e6abaa1c23c5/install/
 
in RHEV 3.5 

2. The command only triggers InstallVdsInternalCommand and there is no option to upgrade the hypervisor.

Actual results:

No option to upgrade the hypervisor through api

Expected results:

Hypervisor upgrade should be possible through api.

Additional info:

Comment 7 Pavol Brilla 2015-12-10 11:22:53 UTC
Jenkins automation unit test passed:

17:46:50 2015-12-03 17:46:53,627 - MainThread - plmanagement.unittest_loader - INFO - tearDown: UpgradeHosts.test_upgrade_rhevh_hosts
17:46:50 2015-12-03 17:46:53,906 - MainThread - plmanagement.unittest_loader - INFO - Status: Pass

Comment 9 errata-xmlrpc 2016-03-09 21:14:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html