Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours

Bug 1279186

Summary: SELinux is preventing brcupsconfpt1 from using the 'execmem' accesses on a process.
Product: [Fedora] Fedora Reporter: Florian Rolland <florian.rolland>
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 23CC: bjsam777, b.moya, doctorrrrrrr, dominick.grift, dsessoms, dwalsh, lvrabec, mgrepl, plautrba, rf.av, rhodeschristopherb
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:e4c7adf72bd18f54a54f952d7e918221f08288f8a16ee185e923cd410c5a19bf;VARIANT_ID=workstation;
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-11-20 05:00:53 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Florian Rolland 2015-11-08 08:32:08 EST
Description of problem:
SELinux is preventing brcupsconfpt1 from using the 'execmem' accesses on a process.

*****  Plugin catchall_boolean (89.3 confidence) suggests   ******************

If vous souhaitez allow cups to execmem
Then vous devez en informer SELinux en activant le booléen « cups_execmem ».
Vous pouvez lire la page de manuel « None » pour plus de détails.
Do
setsebool -P cups_execmem 1

*****  Plugin catchall (11.6 confidence) suggests   **************************

If vous pensez que brcupsconfpt1 devrait être autorisé à accéder execmem sur les processus étiquetés cupsd_t par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep brcupsconfpt1 /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:cupsd_t:s0-s0:c0.c1023
Target Context                system_u:system_r:cupsd_t:s0-s0:c0.c1023
Target Objects                Unknown [ process ]
Source                        brcupsconfpt1
Source Path                   brcupsconfpt1
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-152.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.2.5-300.fc23.x86_64 #1 SMP Tue
                              Oct 27 04:29:56 UTC 2015 x86_64 x86_64
Alert Count                   2
First Seen                    2015-11-08 14:28:15 CET
Last Seen                     2015-11-08 14:28:15 CET
Local ID                      5eedaf28-e04f-4ee9-9f64-209c6a5c94b9

Raw Audit Messages
type=AVC msg=audit(1446989295.299:944): avc:  denied  { execmem } for  pid=5072 comm="brdcp195cfilter" scontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tcontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tclass=process permissive=0


Hash: brcupsconfpt1,cupsd_t,cupsd_t,process,execmem

Version-Release number of selected component:
selinux-policy-3.13.1-152.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.5-300.fc23.x86_64
type:           libreport

Potential duplicate: bug 1258238
Comment 1 Miroslav Grepl 2015-11-20 05:00:53 EST
*****  Plugin catchall_boolean (89.3 confidence) suggests   ******************

If vous souhaitez allow cups to execmem
Then vous devez en informer SELinux en activant le booléen « cups_execmem ».
Vous pouvez lire la page de manuel « None » pour plus de détails.
Do
setsebool -P cups_execmem 1
Comment 2 dsessoms 2015-11-26 05:54:28 EST
Description of problem:
Installed linux-brprinter-installer-2.0.0-1 which was downloaded from http://support.brother.com/g/b/downloadhowto.aspx?c=us&lang=en&prod=mfcj6710dw_all&os=127&dlid=dlf006893_000&flang=4&type3=625

Any attempt to print will generate SELinux error.

I followed instructions on SElinux troubleshooter and did get a page to print.

Previous solution was to set SElinux to permissive.

Version-Release number of selected component:
selinux-policy-3.13.1-154.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.6-300.fc23.x86_64
type:           libreport
Comment 3 Christopher Rhodes 2016-01-06 18:56:16 EST
Description of problem:
Notified of an error and unable to print wirelessly

Version-Release number of selected component:
selinux-policy-3.13.1-158.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.8-300.fc23.x86_64
type:           libreport
Comment 4 Benito Moya 2016-02-20 11:13:25 EST
Description of problem:
Al instalar una página de prueba en la impresora Brother MFC-J5320DW después de realizar la instalación de la misma

Version-Release number of selected component:
selinux-policy-3.13.1-152.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.3-300.fc23.x86_64
type:           libreport
Comment 5 vafr 2016-02-20 16:54:40 EST
Description of problem:
printing to Brotere mfc-j5620dw printer

setenforce 0 is the advice of Brother but seems to be a littele bit too easy.... 

Version-Release number of selected component:
selinux-policy-3.13.1-158.6.fc23.noarch

Additional info:
reporter:       libreport-2.6.4
hashmarkername: setroubleshoot
kernel:         4.3.5-300.fc23.x86_64
type:           libreport
Comment 6 Daniel Walsh 2016-02-22 17:06:07 EST
Maybe someone should tell Brother to fix their code.

Or at least tell them to advise the users to execute

*****  Plugin catchall_boolean (89.3 confidence) suggests   ******************

If vous souhaitez allow cups to execmem
Then vous devez en informer SELinux en activant le booléen « cups_execmem ».
Vous pouvez lire la page de manuel « None » pour plus de détails.
Do
setsebool -P cups_execmem 1
Comment 7 bjsam777 2016-04-24 11:15:29 EDT
Description of problem:
I have a Print Brother DCP-j152w and I try to install on Fedora 23 Cinnamon and the system install the drivers correctly, but when I wanna Print someone file the software show me "send File" and then show me "priting complete" but hardware do not print. when I try giving solution to problems from "config-printing-settings"  show me  this:
Page 1 (<troubleshoot.SchedulerNotRunning.SchedulerNotRunning object at 0xafcc6e2c>):
{'cups_connection_failure': False}
Page 2 (<troubleshoot.ChoosePrinter.ChoosePrinter object at 0xafcc6d0c>):
{'cups_dest': <cups.Dest DCPJ152W (default)>,
 'cups_instance': None,
 'cups_queue': 'DCPJ152W',
 'cups_queue_listed': True}
Page 3 (<troubleshoot.CheckPrinterSanity.CheckPrinterSanity object at 0xafcc6cec>):
{'cups_device_uri_scheme': 'dnssd',
 'cups_printer_dict': {'device-uri': 'dnssd://Brother%20DCP-J152W._ipp._tcp.local/?uuid=e3248000-80ce-11db-8000-0071cc03b633',
                       'printer-info': 'DCPJ152W',
                       'printer-is-shared': True,
                       'printer-location': '',
                       'printer-make-and-model': 'Brother DCP-J152W CUPS',
                       'printer-state': 3,
                       'printer-state-message': '',
                       'printer-state-reasons': ['none'],
                       'printer-type': 8392716,
                       'printer-uri-supported': 'ipp://localhost/printers/DCPJ152W'},
 'cups_printer_remote': False,
 'is_cups_class': False,
 'local_cups_queue_attributes': {'charset-configured': 'utf-8',
                                 'charset-supported': ['us-ascii', 'utf-8'],
                                 'color-supported': True,
                                 'compression-supported': ['none', 'gzip'],
                                 'copies-default': 1,
                                 'copies-supported': (1, 9999),
                                 'cups-version': '2.1.3',
                                 'device-uri': 'dnssd://Brother%20DCP-J152W._ipp._tcp.local/?uuid=e3248000-80ce-11db-8000-0071cc03b633',
                                 'document-format-default': 'application/octet-stream',
                                 'document-format-supported': ['application/octet-stream',
                                                               'application/pdf',
                                                               'application/postscript',
                                                               'application/vnd.adobe-reader-postscript',
                                                               'application/vnd.cups-command',
                                                               'application/vnd.cups-pdf',
                                                               'application/vnd.cups-pdf-banner',
                                                               'application/vnd.cups-postscript',
                                                               'application/vnd.cups-raster',
                                                               'application/vnd.cups-raw',
                                                               'application/x-cshell',
                                                               'application/x-csource',
                                                               'application/x-perl',
                                                               'application/x-shell',
                                                               'image/gif',
                                                               'image/jpeg',
                                                               'image/png',
                                                               'image/pwg-raster',
                                                               'image/tiff',
                                                               'image/x-bitmap',
                                                               'image/x-photocd',
                                                               'image/x-portable-anymap',
                                                               'image/x-portable-bitmap',
                                                               'image/x-portable-graymap',
                                                               'image/x-portable-pixmap',
                                                               'image/x-sgi-rgb',
                                                               'image/x-sun-raster',
                                                               'image/x-xbitmap',
                                                               'image/x-xpixmap',
                                                               'image/x-xwindowdump',
                                                               'text/css',
                                                               'text/html',
                                                               'text/plain'],
                                 'finishings-default': 3,
                                 'finishings-supported': [3],
                                 'generated-natural-language-supported': ['es-cl'],
                                 'ipp-features-supported': ['subscription-object'],
                                 'ipp-versions-supported': ['1.0',
                                                            '1.1',
                                                            '2.0',
                                                            '2.1'],
                                 'ippget-event-life': 15,
                                 'job-cancel-after-default': 10800,
                                 'job-cancel-after-supported': (0,
                                                                2147483647),
                                 'job-creation-attributes-supported': ['copies',
                                                                       'finishings',
                                                                       'ipp-attribute-fidelity',
                                                                       'job-hold-until',
                                                                       'job-name',
                                                                       'job-priority',
                                                                       'job-sheets',
                                                                       'media',
                                                                       'media-col',
                                                                       'multiple-document-handling',
                                                                       'number-up',
                                                                       'output-bin',
                                                                       'orientation-requested',
                                                                       'page-ranges',
                                                                       'print-color-mode',
                                                                       'print-quality',
                                                                       'printer-resolution',
                                                                       'sides'],
                                 'job-hold-until-default': 'no-hold',
                                 'job-hold-until-supported': ['no-hold',
                                                              'indefinite',
                                                              'day-time',
                                                              'evening',
                                                              'night',
                                                              'second-shift',
                                                              'third-shift',
                                                              'weekend'],
                                 'job-ids-supported': True,
                                 'job-k-limit': 0,
                                 'job-k-octets-supported': (0, 95985428),
                                 'job-page-limit': 0,
                                 'job-priority-default': 50,
                                 'job-priority-supported': [100],
                                 'job-quota-period': 0,
                                 'job-settable-attributes-supported': ['copies',
                                                                       'finishings',
                                                                       'job-hold-until',
                                                                       'job-name',
                                                                       'job-priority',
                                                                       'media',
                                                                       'media-col',
                                                                       'multiple-document-handling',
                                                                       'number-up',
                                                                       'output-bin',
                                                                       'orientation-requested',
                                                                       'page-ranges',
                                                                       'print-color-mode',
                                                                       'print-quality',
                                                                       'printer-resolution',
                                                                       'sides'],
                                 'job-sheets-default': ('none', 'none'),
                                 'job-sheets-supported': ['none',
                                                          'classified',
                                                          'confidential',
                                                          'form',
                                                          'secret',
                                                          'standard',
                                                          'topsecret',
                                                          'unclassified'],
                                 'jpeg-k-octets-supported': (0, 95985428),
                                 'jpeg-x-dimension-supported': (0, 65535),
                                 'jpeg-y-dimension-supported': (1, 65535),
                                 'marker-change-time': 1461467038,
                                 'marker-colors': ['#000000',
                                                   '#FFFF00',
                                                   '#00FFFF',
                                                   '#FF00FF',
                                                   'none'],
                                 'marker-levels': [-1, -1, -1, -1, -1],
                                 'marker-names': ['Black Ink Cartridge',
                                                  'Yellow Ink Cartridge',
                                                  'Cyan Ink Cartridge',
                                                  'Magenta Ink Cartridge',
                                                  'Ink Absorber'],
                                 'marker-types': ['ink-cartridge',
                                                  'ink-cartridge',
                                                  'ink-cartridge',
                                                  'ink-cartridge',
                                                  'waste-ink'],
                                 'media-bottom-margin-supported': [318,
                                                                   35,
                                                                   2187],
                                 'media-col-supported': ['media-bottom-margin',
                                                         'media-left-margin',
                                                         'media-right-margin',
                                                         'media-size',
                                                         'media-source',
                                                         'media-top-margin',
                                                         'media-type'],
                                 'media-default': 'na_letter_8.5x11in',
                                 'media-left-margin-supported': [318, 35],
                                 'media-right-margin-supported': [318, 35],
                                 'media-supported': ['iso_a4_210x297mm',
                                                     'na_letter_8.5x11in',
                                                     'na_legal_8.5x14in',
                                                     'na_executive_7.25x10.5in',
                                                     'iso_a5_148x210mm',
                                                     'iso_a6_105x148mm',
                                                     'jis_b5_182x257mm',
                                                     'oe_br-post-c-4x-6-b_4x6in',
                                                     'oe_br-index-c-5x-8-b_5x8in',
                                                     'oe_br-photo-l-b_3.5x5in',
                                                     'om_br-photo-2-l-b_126.65x178.15mm',
                                                     'jpn_hagaki_100x148mm',
                                                     'jpn_oufuku_148x200mm',
                                                     'iso_dl_110x220mm',
                                                     'iso_c5_162x229mm',
                                                     'na_number-10_4.125x9.5in',
                                                     'na_monarch_3.875x7.5in',
                                                     'jpn_you4_105x235mm',
                                                     'jpn_chou3_120x235mm',
                                                     'jpn_chou4_90x205mm',
                                                     'iso_c6_114x162mm'],
                                 'media-top-margin-supported': [318,
                                                                35,
                                                                2187,
                                                                1199],
                                 'multiple-document-handling-supported': ['separate-documents-uncollated-copies',
                                                                          'separate-documents-collated-copies'],
                                 'multiple-document-jobs-supported': True,
                                 'multiple-operation-time-out': 300,
                                 'multiple-operation-time-out-action': 'process-job',
                                 'natural-language-configured': 'es-cl',
                                 'notify-attributes-supported': ['printer-state-change-time',
                                                                 'notify-lease-expiration-time',
                                                                 'notify-subscriber-user-name'],
                                 'notify-events-default': ['job-completed'],
                                 'notify-events-supported': ['job-completed',
                                                             'job-config-changed',
                                                             'job-created',
                                                             'job-progress',
                                                             'job-state-changed',
                                                             'job-stopped',
                                                             'printer-added',
                                                             'printer-changed',
                                                             'printer-config-changed',
                                                             'printer-deleted',
                                                             'printer-finishings-changed',
                                                             'printer-media-changed',
                                                             'printer-modified',
                                                             'printer-restarted',
                                                             'printer-shutdown',
                                                             'printer-state-changed',
                                                             'printer-stopped',
                                                             'server-audit',
                                                             'server-restarted',
                                                             'server-started',
                                                             'server-stopped'],
                                 'notify-lease-duration-default': 86400,
                                 'notify-lease-duration-supported': (0,
                                                                     2147483647),
                                 'notify-max-events-supported': [100],
                                 'notify-pull-method-supported': ['ippget'],
                                 'notify-schemes-supported': ['dbus',
                                                              'mailto',
                                                              'rss'],
                                 'number-up-default': 1,
                                 'number-up-supported': [1, 2, 4, 6, 9, 16],
                                 'operations-supported': [2,
                                                          4,
                                                          5,
                                                          6,
                                                          8,
                                                          9,
                                                          10,
                                                          11,
                                                          12,
                                                          13,
                                                          16,
                                                          17,
                                                          18,
                                                          19,
                                                          20,
                                                          21,
                                                          22,
                                                          23,
                                                          24,
                                                          25,
                                                          26,
                                                          27,
                                                          28,
                                                          34,
                                                          35,
                                                          37,
                                                          38,
                                                          56,
                                                          57,
                                                          59,
                                                          16385,
                                                          16386,
                                                          16387,
                                                          16388,
                                                          16389,
                                                          16390,
                                                          16391,
                                                          16392,
                                                          16393,
                                                          16394,
                                                          16395,
                                                          16396,
                                                          16397,
                                                          16398,
                                                          16399,
                                                          16423,
                                                          14],
                                 'orientation-requested-default': None,
                                 'orientation-requested-supported': [3,
                                                                     4,
                                                                     5,
                                                                     6],
                                 'output-bin-default': 'face-down',
                                 'output-bin-supported': ['face-down'],
                                 'page-ranges-supported': True,
                                 'pages-per-minute': 12,
                                 'pages-per-minute-color': 12,
                                 'pdf-k-octets-supported': (0, 95985428),
                                 'pdf-versions-supported': ['adobe-1.2',
                                                            'adobe-1.3',
                                                            'adobe-1.4',
                                                            'adobe-1.5',
                                                            'adobe-1.6',
                                                            'adobe-1.7',
                                                            'iso-19005-1_2005',
                                                            'iso-32000-1_2008',
                                                            'pwg-5102.3'],
                                 'pdl-override-supported': ['attempted'],
                                 'port-monitor': 'none',
                                 'port-monitor-supported': ['none'],
                                 'print-color-mode-default': 'color',
                                 'print-color-mode-supported': ['monochrome',
                                                                'color'],
                                 'print-quality-default': 4,
                                 'print-quality-supported': [4],
                                 'printer-commands': ['AutoConfigure',
                                                      'Clean',
                                                      'PrintSelfTestPage'],
                                 'printer-config-change-date-time': '(IPP_TAG_DATE)',
                                 'printer-config-change-time': 1461466849,
                                 'printer-current-time': '(IPP_TAG_DATE)',
                                 'printer-device-id': 'MFG:Brother;MDL:DCP-J152W',
                                 'printer-dns-sd-name': 'DCPJ152W @ linux',
                                 'printer-error-policy': 'stop-printer',
                                 'printer-error-policy-supported': ['abort-job',
                                                                    'retry-current-job',
                                                                    'retry-job',
                                                                    'stop-printer'],
                                 'printer-geo-location': '(unknown IPP '
                                                         'value tag 0x12)',
                                 'printer-get-attributes-supported': ['document-format'],
                                 'printer-icons': 'http://localhost/icons/DCPJ152W.png',
                                 'printer-info': 'DCPJ152W',
                                 'printer-is-accepting-jobs': True,
                                 'printer-is-shared': True,
                                 'printer-location': '',
                                 'printer-make-and-model': 'Brother '
                                                           'DCP-J152W CUPS',
                                 'printer-more-info': 'http://localhost/printers/DCPJ152W',
                                 'printer-name': 'DCPJ152W',
                                 'printer-op-policy': 'default',
                                 'printer-op-policy-supported': ['authenticated',
                                                                 'default'],
                                 'printer-organization': '',
                                 'printer-organizational-unit': '',
                                 'printer-resolution-default': (300, 300, 3),
                                 'printer-resolution-supported': [(300,
                                                                   300,
                                                                   3)],
                                 'printer-settable-attributes-supported': ['printer-geo-location',
                                                                           'printer-info',
                                                                           'printer-location',
                                                                           'printer-organization',
                                                                           'printer-organizational-unit'],
                                 'printer-state': 3,
                                 'printer-state-change-date-time': '(IPP_TAG_DATE)',
                                 'printer-state-change-time': 1461467038,
                                 'printer-state-message': '',
                                 'printer-state-reasons': ['none'],
                                 'printer-supply': ['(unknown IPP value '
                                                    'tag 0x30)',
                                                    '(unknown IPP value '
                                                    'tag 0x30)',
                                                    '(unknown IPP value '
                                                    'tag 0x30)',
                                                    '(unknown IPP value '
                                                    'tag 0x30)',
                                                    '(unknown IPP value '
                                                    'tag 0x30)'],
                                 'printer-supply-description': ['Black Ink '
                                                                'Cartridge',
                                                                'Yellow '
                                                                'Ink '
                                                                'Cartridge',
                                                                'Cyan Ink '
                                                                'Cartridge',
                                                                'Magenta '
                                                                'Ink '
                                                                'Cartridge',
                                                                'Ink '
                                                                'Absorber'],
                                 'printer-type': 8392716,
                                 'printer-up-time': 1461467063,
                                 'printer-uri-supported': ['ipp://localhost/printers/DCPJ152W'],
                                 'printer-uuid': 'urn:uuid:59320c0e-64c4-349c-67c9-7b695050cc8d',
                                 'queued-job-count': 0,
                                 'server-is-sharing-printers': True,
                                 'sides-default': 'one-sided',
                                 'sides-supported': ['one-sided'],
                                 'uri-authentication-supported': ['requesting-user-name'],
                                 'uri-security-supported': ['none'],
                                 'which-jobs-supported': ['completed',
                                                          'not-completed',
                                                          'aborted',
                                                          'all',
                                                          'canceled',
                                                          'pending',
                                                          'pending-held',
                                                          'processing',
                                                          'processing-stopped']}}
Page 4 (<troubleshoot.CheckPPDSanity.CheckPPDSanity object at 0xafcc6c8c>):
{'cups_printer_ppd_defaults': {'Color Settings': {'BRColorMatching': 'Vivid'},
                               'Color Settings (Advanced)': {'BRBlue': '0',
                                                             'BRBrightness': '0',
                                                             'BRColorEnhancement': 'OFF',
                                                             'BRContrast': '0',
                                                             'BRGreen': '0',
                                                             'BRHalfTonePattern': 'Diffusion',
                                                             'BRRed': '0'},
                               'General': {'PageRegion': 'Letter',
                                           'PageSize': 'Letter'},
                               'Print Settings': {'BRMediaType': 'Plain',
                                                  'BRMonoColor': 'Color',
                                                  'BRResolution': 'PlainNormal',
                                                  'BRSlowDrying': 'OFF'},
                               'Print Settings (Advanced)': {'BRBiDir': 'ON',
                                                             'BRColorPaperThick': 'Regular',
                                                             'BRDuplexMode': 'Normal',
                                                             'BRJpeg': 'Recommended'}},
 'cups_printer_ppd_valid': True,
 'missing_pkgs_and_exes': ([], [])}
Page 5 (<troubleshoot.LocalOrRemote.LocalOrRemote object at 0xafcc6cac>):
{'printer_is_remote': False}
Page 6 (<troubleshoot.DeviceListed.DeviceListed object at 0xafc0780c>):
{'cups_device_dict': {'device-class': 'network',
                      'device-id': 'MFG:Brother;MDL:DCP-J152W;CMD:HBP,BRPJL,URF;FZY:0;',
                      'device-info': 'Brother DCP-J152W',
                      'device-make-and-model': 'Brother DCP-J152W'}}
Page 7 (<troubleshoot.VerifyPackages.VerifyPackages object at 0xafc603ec>):
{'packages_verification': {'cups': ['.M.......  c /etc/cups/client.conf',
                                    '..?......    '
                                    '/usr/lib/cups/backend/dnssd',
                                    '..?......    /usr/lib/cups/backend/ipp',
                                    '..?......    /usr/lib/cups/backend/lpd'],
                           'foomatic': [],
                           'gutenprint': [],
                           'hpijs': ['package hpijs is not installed'],
                           'hplip': ['..?......    /usr/lib/cups/backend/hp',
                                     '..?......    '
                                     '/usr/lib/cups/backend/hpfax'],
                           'system-config-printer': []}}
Page 8 (<troubleshoot.PrintTestPage.PrintTestPage object at 0xafc227ec>):
{'test_page_attempted': '24/abr/2016:00:04:39 -0300',
 'test_page_completions': [(51, 'Job completed.')],
 'test_page_job_id': [51],
 'test_page_job_status': [(True,
                           51,
                           'DCPJ152W',
                           'Test Page',
                           'Completed',
                           {'attributes-charset': 'utf-8',
                            'attributes-natural-language': 'es-cl',
                            'date-time-at-completed': '(IPP_TAG_DATE)',
                            'date-time-at-creation': '(IPP_TAG_DATE)',
                            'date-time-at-processing': '(IPP_TAG_DATE)',
                            'document-format': 'application/vnd.cups-pdf-banner',
                            'document-format-detected': 'application/vnd.cups-pdf-banner',
                            'job-hold-until': 'no-hold',
                            'job-id': 51,
                            'job-impressions-completed': 0,
                            'job-k-octets': 1,
                            'job-media-progress': 0,
                            'job-media-sheets-completed': 0,
                            'job-more-info': 'http://localhost/jobs/51',
                            'job-preserved': False,
                            'job-printer-state-message': '',
                            'job-printer-state-reasons': ['none'],
                            'job-printer-up-time': 1461467089,
                            'job-printer-uri': 'ipp://localhost/printers/DCPJ152W',
                            'job-priority': 50,
                            'job-sheets': ['none', 'none'],
                            'job-state': 9,
                            'job-state-reasons': 'processing-to-stop-point',
                            'job-uri': 'ipp://localhost/jobs/51',
                            'job-uuid': 'urn:uuid:23552933-4fd4-30dc-5e89-c43a3c131d81',
                            'number-of-documents': 0,
                            'printer-uri': 'ipp://localhost/printers/DCPJ152W',
                            'time-at-completed': 1461467081,
                            'time-at-creation': 1461467079,
                            'time-at-processing': 1461467079})],
 'test_page_successful': False}
Page 9 (<troubleshoot.Locale.Locale object at 0xafcc4b0c>):
{'printer_page_size': 'Letter',
 'system_locale_lang': 'es_CL',
 'user_locale_ctype': 'es_CL',
 'user_locale_messages': 'es_CL'}

Please help me.



Version-Release number of selected component:
selinux-policy-3.13.1-158.14.fc23.noarch

Additional info:
reporter:       libreport-2.6.4
hashmarkername: setroubleshoot
kernel:         4.2.3-300.fc23.i686
type:           libreport