Bug 128305

Summary: xscreensaver trips log updates which spin up my disk
Product: [Fedora] Fedora Reporter: Pete Zaitcev <zaitcev>
Component: xorg-x11Assignee: Mike A. Harris <mharris>
Status: CLOSED RAWHIDE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 2CC: xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-10-14 14:24:03 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 130887    

Description Pete Zaitcev 2004-07-21 12:07:59 EDT
On my laptop, I like to shut down my drive, but xscreensaver keeps
spinning it up.

[root@localhost linux-2.6.7-ub]# find /var -mtime -1 | xargs ls -lt |
head -10
-rw-r--r--  1 root    root      153337 Jul 21 09:09 /var/log/messages
-rw-r--r--  1 root    root        1597 Jul 21 09:02 /var/log/gdm/:0.log
-rw-r--r--  1 root    root       34614 Jul 21 09:02 /var/log/XFree86.0.log
-rw-r--r--  1 root    root         772 Jul 21 08:32
/var/lib/dhcp/dhclient-eth1.leases
-rw-r--r--  1 root    root           5 Jul 21 08:32
/var/run/dhclient-eth1.pid
-rw-------  1 root    root       22851 Jul 21 08:24 /var/log/boot.log
-rw-rw-r--  1 root    utmp      106752 Jul 21 08:22 /var/log/wtmp
-rw-rw-r--  1 root    utmp        5376 Jul 21 08:22 /var/run/utmp
-rw-r--r--  1 root    root          38 Jul 21 08:21 /var/gdm/:0.Xservers
-r--------  1 root    root    19136220 Jul 21 08:21 /var/log/lastlog
xargs: ls: terminated by signal 13
[root@localhost linux-2.6.7-ub]# tail /var/log/gdm/:0.log
(==) Using config file: "/etc/X11/XF86Config"
GetModeLine - scrn: 0 clock: 65000
GetModeLine - hdsp: 1024 hbeg: 1048 hend: 1184 httl: 1344
              vdsp: 768 vbeg: 771 vend: 777 vttl: 806 flags: 10
GetModeLine - scrn: 0 clock: 65000
GetModeLine - hdsp: 1024 hbeg: 1048 hend: 1184 httl: 1344
              vdsp: 768 vbeg: 771 vend: 777 vttl: 806 flags: 10
GetModeLine - scrn: 0 clock: 65000
GetModeLine - hdsp: 1024 hbeg: 1048 hend: 1184 httl: 1344
              vdsp: 768 vbeg: 771 vend: 777 vttl: 806 flags: 10
[root@localhost linux-2.6.7-ub]# tail /var/log/XFree86.0.log
(II) DevInputMice: ps2EnableDataReporting: succeeded
GetModeLine - scrn: 0 clock: 65000
GetModeLine - hdsp: 1024 hbeg: 1048 hend: 1184 httl: 1344
              vdsp: 768 vbeg: 771 vend: 777 vttl: 806 flags: 10
GetModeLine - scrn: 0 clock: 65000
GetModeLine - hdsp: 1024 hbeg: 1048 hend: 1184 httl: 1344
              vdsp: 768 vbeg: 771 vend: 777 vttl: 806 flags: 10
GetModeLine - scrn: 0 clock: 65000
GetModeLine - hdsp: 1024 hbeg: 1048 hend: 1184 httl: 1344
              vdsp: 768 vbeg: 771 vend: 777 vttl: 806 flags: 10
[root@localhost linux-2.6.7-ub]#
Comment 1 Mike A. Harris 2004-08-02 00:31:34 EDT
Thanks Pete.  I'll change the default verbosity for that line to
one notch higher so it doesn't normally appear in the logfile.  I've
never personally found the GetModeLine log entries useful ever, so
they wont be missed by me at least.  ;o)

This is rather important for laptops, so I'm marking this as a
FC3 TARGET bug, but it'll probably get put into FC2, FC1 erratum
also.

Comment 2 Kevin E. Martin 2004-09-27 15:14:45 EDT
XFree86-VidModeExtension displays these messages in the log file if
the verbosity level is >1 (see .../Xserver/Xext/xf86vmode.c).  For it
to not show up in the log file, the verbosity tests need to be >3.

Unfortunately, this test is currently hard coded everywhere in the
file.  It should be changed to use a #define, which can be placed at
the top of the file:
  #define DEFAULT_XF86VIDMODE_VERBOSITY 3
and then each test:
  if (xf86GetVerbosity() > 1) {
could be changed to:
  if (xf86GetVerbosity() > DEFAULT_XF86VIDMODE_VERBOSITY) {

This should also be submitted upstream for consideration.
Comment 3 Mike A. Harris 2004-09-27 15:26:56 EDT
I'll take resonsibility for this one.  Reassigning to myself.
Comment 4 Mike A. Harris 2004-10-07 00:33:56 EDT
I've modified the Xvidmode extension to only log these messages
when (xf86GetVerbosity() > DEFAULT_XF86VIDMODE_VERBOSITY), and
set DEFAULT_XF86VIDMODE_VERBOSITY==3 to 3, which is the default
X server log file verbosity level.  This should cause all
vidmode extension messages to continue to be written to the
console et al., but not to the log file.

I have submitted my patch upstream at:
    http://freedesktop.org/bugzilla/show_bug.cgi?id=1552

The xorg-x11-6.8.1-5 build contains this enhancement, and is
currently building in our buildsystem.  Please test the new
build out once it is available and provide feedback on the
testing results.  There should no longer be vidmode related
logfile messages unless you change the logfile verbosity to
4 or greater.

Setting RFE status to "MODIFIED" state pending testing results.
Once this has been tested, please set to "ASSIGNED" state
with status update if problems occur, or set to "RAWHIDE" if
the patch is confirmed to work.

Thanks in advance for testing.
Comment 5 Jay Turner 2004-10-14 08:20:58 EDT
Pete, does this look any better to you now?
Comment 6 Pete Zaitcev 2004-10-14 11:31:30 EDT
I am sorry, I haven't tested it yet, primarily because I received
a laptop where the hard drive is not as noisy... Please close if it
bothers you.
Comment 7 Mike A. Harris 2004-10-14 14:24:03 EDT
Hi guys,

We've had independant confirmation that the patch works for people.
It's submitted upstream as well and should be the default in
X11 6.9.0.

Thanks.

Setting status to "RAWHIDE"