Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.

Bug 128621

Summary: festival is not available for x86_64 architecture
Product: [Fedora] Fedora Reporter: Thomas Zehetbauer <thomasz>
Component: festivalAssignee: Jonathan Blandford <jrb>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: axel.thimm, byte, ddumas, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-09-24 18:04:23 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
build log none

Description Thomas Zehetbauer 2004-07-27 06:26:04 EDT
Description of problem:
festival is not available for the x86_64 architecture, the i386 build
does run fine after satisfying 32-bit libtermcap dependency

Version-Release number of selected component (if applicable):
1.4.2-22
Comment 1 Bill Nottingham 2004-08-06 17:32:27 EDT
Does a native 64-bit build (if built by hand) work?
Comment 2 Thomas Zehetbauer 2004-08-07 16:59:26 EDT
Created attachment 102504 [details]
build log

Negative, see the attached log file with the output of
rpm -bb with the original specfile
rpm -bb with ExclusiveArch removed from the specfile
manual build attempt
Comment 3 Colin Charles 2004-09-19 02:34:19 EDT
It is also not being built on powerpc and ppc64 with the current
rawhide tree. URLs to look at confirming this:
http://download.fedora.redhat.com/pub/fedora/linux/core/development/ppc64/Fedora/RPMS/

gnome-speech has a dependency on festival, so this also means that
gnome-speech isn't available on ppc/ppc64
Comment 4 Warren Togami 2004-09-19 07:23:36 EDT
I believe festival is an artificial dependency in gnome-speech. 
Unless festival can be made to build on other archs, we should
probably back out that artificial dep.
Comment 5 Jonathan Blandford 2004-09-19 10:54:14 EDT
gnome-speech doesn't really require festival to work.  It is a set of
drivers (you could use it with a hardware speech card for instance),
but using it with festival is the common case.  The dependency is i386
only.
Comment 6 Warren Togami 2004-09-19 17:12:30 EDT
I suppose a %ifarch conditional Requires would work?
Comment 7 Jonathan Blandford 2004-09-20 11:24:47 EDT
It has that already. (-:  I don't think that's what this bug is about,
though.
Comment 8 Colin Charles 2004-09-20 19:57:30 EDT
No, the bug's about getting festival built elsewhere. Can we do that?
Because gnome-speech is useless w/o it :)
Comment 9 Thomas Zehetbauer 2004-09-21 07:05:30 EDT
gnome-speech-0.3.5-1.x86_64 seems to work with festival-1.4.2-25.i386
here.
Comment 10 Thomas Zehetbauer 2004-09-24 18:04:23 EDT
I am closing this bug as festival-1.4.2-25.i386.rpm is now included in
x86_64 rawhide.
Comment 11 Axel Thimm 2005-01-30 00:14:55 EST
There is still the open question whether festival can be built
natively on x86_64 and others. According to the project group in
Edinbourgh it is supposed to be portable.

Not everything can be built against the i386 package. Could someone
reopen this?