Bug 1286217

Summary: Under wayland, openmsx cannot use 640x480 full screen mode.
Product: [Fedora] Fedora Reporter: Sean Young <sean>
Component: waylandAssignee: Adam Jackson <ajax>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 23CC: ajax, kparal
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-12-08 19:01:17 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1277927    

Description Sean Young 2015-11-27 12:59:51 UTC
Description of problem:
Log in with GNOME under Wayland

Version-Release number of selected component (if applicable):
openmsx 0.11.0

How reproducible:
1. Run openmsx from bash
2. Press F12
3. openmsx should go to fullscreen at 640x480.


Steps to Reproduce:
1.
2.
3.

Actual results:
Mode remains 1920x1024; msx is not really fullscreen, it's in the center.

Expected results:


Additional info:
snes9x-gtk suffers from the same issue.
1. run snes9x-gtk from command line
2. Go to Option -> Preferences -> Display -> Change fullscreen resolution.
3. Here many modes should be available.

Comment 1 Kamil Páral 2015-12-08 19:01:17 UTC
I believe this is the same core issue as in bug 1289714.

*** This bug has been marked as a duplicate of bug 1289714 ***