Bug 1286506

Summary: qemu-kvm core dumped when booting qemu-kvm process with queues=0 and vhost-user
Product: Red Hat Enterprise Linux 7 Reporter: FuXiangChun <xfu>
Component: qemu-kvm-rhevAssignee: Victor Kaplansky <vkaplans>
Status: CLOSED ERRATA QA Contact: Virtualization Bugs <virt-bugs>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 7.2CC: ailan, chayang, jen, juzhang, knoel, michen, mst, pezhang, victork, virt-maint, vkaplans, weliao
Target Milestone: rc   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: qemu-kvm-rhev-2.5.0-1.el7 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-11-07 21:39:44 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1305606, 1313485, 1288337    

Comment 5 FuXiangChun 2016-05-26 01:59:17 UTC
Verified this bug with qemu-kvm-rhev-2.6.0-3.el7.

result:
/usr/libexec/qemu-kvm -m 3G,maxmem=4G,slots=4 -smp 4 -chardev socket,id=charnet0,path=/var/run/openvswitch/vhost-user2 -netdev type=vhost-user,id=hostnet0,queues=0,chardev=charnet0 -device virtio-net-pci,mq=on,vectors=10,netdev=hostnet0,id=net0,mac=52:54:00:01:0b:12,bus=pci.0,addr=0x9,ctrl_vlan=off,status=on

qemu-kvm: -netdev type=vhost-user,id=hostnet0,queues=0,chardev=charnet0: vhost-user number of queues must be in range [1, 1024]

As queues=0 has no meaning. qemu-kvm-rhev and libvirt prevented queues=0 this setting.  It makes sense.

Comment 6 juzhang 2016-06-23 07:59:52 UTC
According to comment5, set this issue as verified.

Comment 8 errata-xmlrpc 2016-11-07 21:39:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2673.html