Bug 1287056 (CVE-2015-8366)

Summary: CVE-2015-8366 LibRaw: Index overflow in smal_decode_segment
Product: [Other] Security Response Reporter: Adam Mariš <amaris>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: alekcejk, carnil, debarshir, gwync, jreznik, ltinkl, mattdm, nphilipp, rdieter, rnovacek, sebastian, siddharth.kde, than, thibault.north
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: LibRaw 0.17.1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-10-27 12:55:58 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1287057    
Bug Blocks: 1287081    

Description Adam Mariš 2015-12-01 12:04:21 UTC
It was found that smal_decode_segment function do not handle index carefully, which may cause index overflow.

Upstream patch:

https://github.com/LibRaw/LibRaw/commit/89d065424f09b788f443734d44857289489ca9e2

Comment 1 Adam Mariš 2015-12-01 12:04:37 UTC
Created LibRaw tracking bugs for this issue:

Affects: fedora-all [bug 1287057]

Comment 2 Adam Mariš 2015-12-01 13:17:40 UTC
Public via:

http://seclists.org/fulldisclosure/2015/Nov/108