Bug 129018

Summary: JVM crashes randomly
Product: Red Hat Network Reporter: Mike McCune <mmccune>
Component: RHN/R&DAssignee: Mike McCune <mmccune>
Status: CLOSED CURRENTRELEASE QA Contact: Fanny Augustin <fmoquete>
Severity: medium Docs Contact:
Priority: medium    
Version: RHN Devel   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-08-18 12:47:02 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 125080    

Description Mike McCune 2004-08-03 00:21:15 UTC
Once every few days the JVM running Tomcat dies with the following
error in the log.  

This bug is to track progress on determining what is causing this
fatal error.

INFO: Server startup in 5917 ms
#
# HotSpot Virtual Machine Error, Internal Error
# Please report this error at
# http://java.sun.com/cgi-bin/bugreport.cgi
#
# Java VM: Java HotSpot(TM) Client VM (1.4.2_04-b05 mixed mode)
#
# Error ID: 43113F32554E54494D45110E4350500308
#
# Problematic Thread: prio=1 tid=0x0856fef0 nid=0x7f63 runnable 
#

Heap at VM Abort:
Heap
 def new generation   total 1664K, used 1622K [0x44870000, 0x44a30000,
0x44d50000)
  eden space 1536K,  99% used [0x44870000, 0x449effd8, 0x449f0000)
  from space 128K,  67% used [0x44a10000, 0x44a25a50, 0x44a30000)
  to   space 128K,   0% used [0x449f0000, 0x449f0000, 0x44a10000)
 tenured generation   total 20756K, used 16288K [0x44d50000,
0x46195000, 0x48870000)
   the space 20756K,  78% used [0x44d50000, 0x45d381a8, 0x45d38200,
0x46195000)
 compacting perm gen  total 14592K, used 14395K [0x48870000,
0x496b0000, 0x4c870000)
   the space 14592K,  98% used [0x48870000, 0x4967ed68, 0x4967ee00,
0x496b0000)

Comment 1 Jesus M. Rodriguez 2004-08-16 15:09:47 UTC
Ever since we switched to the IBM JVM, I haven't seen this happen.  So
we should leave it open to continue monitoring our progress.

Comment 2 Ryan Bloom 2004-08-18 12:47:02 UTC
we aren't seeing this anymore.  If more segfaults happen, this will
get reopened.