Bug 1296068 (CVE-2015-8725)

Summary: CVE-2015-8725 wireshark: DIAMETER dissector crash (wnpa-sec-2015-43)
Product: [Other] Security Response Reporter: Martin Prpič <mprpic>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: huzaifas, jrusnack, lemenkov, phatina, rvokal
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: wireshark 2.0.1, wireshark 1.12.9 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-01-06 10:28:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1296097    
Bug Blocks:    

Description Martin Prpič 2016-01-06 10:05:50 UTC
It was reported that Wireshark's DIAMETER dissector could crash. It may be possible to make Wireshark crash by injecting a malformed packet onto the wire or by convincing someone to read a malformed packet trace file.

This flaw is fixed in the following Wireshark versions: 2.0.1, 1.12.9.

Upstream bug(s):

https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=11792

External References:

https://www.wireshark.org/security/wnpa-sec-2015-43

Comment 1 Martin Prpič 2016-01-06 10:26:11 UTC
Created wireshark tracking bugs for this issue:

Affects: fedora-all [bug 1296097]