Bug 1296842

Summary: [grep] pcre-count test fails
Product: [Fedora] Fedora Reporter: Rafael Fonseca <rdossant>
Component: grepAssignee: Jaroslav Škarvada <jskarvad>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 22CC: jskarvad, lkundrak, mjuszkie, pbrobinson, rdossant
Target Milestone: ---   
Target Release: ---   
Hardware: powerpc   
OS: Linux   
Whiteboard:
Fixed In Version: grep-2.22-6.fc23 grep-2.21-9.fc22 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-01-14 08:52:10 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1071880, 922257, 1051573    

Description Rafael Fonseca 2016-01-08 09:02:35 UTC
Description of problem: building grep on ppc64/ppc64le fails with

./triple-backref: line 32: 11599 Segmentation fault      (core dumped) grep -E '(.?)(.?)(.?)\3\2\1' in > out

Program received signal SIGSEGV, Segmentation fault.
0x00003fffb7d8903c in free () from /lib64/libc.so.6
Missing separate debuginfos, use: dnf debuginfo-install pcre-8.37-7.fc22.ppc64le
(gdb) bt
#0  0x00003fffb7d8903c in free () from /lib64/libc.so.6
#1  0x00003fffb7d12cf0 in set_regs () from /lib64/libc.so.6
#2  0x00003fffb7df3644 in re_search_internal () from /lib64/libc.so.6
#3  0x00003fffb7df39f4 in re_search_stub () from /lib64/libc.so.6
#4  0x0000000010011c98 in EGexecute (buf=0x10060000 "a\n", 
    size=<optimized out>, match_size=0x3fffffffecb0, start_ptr=0x0)
    at dfasearch.c:349
#5  0x0000000010006814 in grepbuf (beg=<optimized out>, lim=0x10060002 "")
    at grep.c:1263
#6  0x0000000010007844 in grep (st=0x3fffffffeda8, fd=3) at grep.c:1377
#7  grepdesc (desc=<optimized out>, command_line=<optimized out>) at grep.c:1645
#8  0x0000000010003b0c in main (argc=<optimized out>, argv=0x3ffffffff5b8)
    at grep.c:2565

Version-Release number of selected component (if applicable): 2.21-8


How reproducible: always on ppc-koji

Comment 1 Jaroslav Škarvada 2016-01-08 10:47:21 UTC
Please could you check with the rawhide (or f23, it's same as rawhide) package? It would help me to know whether rawhide is also effected.

Comment 2 Rafael Fonseca 2016-01-08 11:00:26 UTC
A mockbuild fails on both f23 and rawhide. Version 2.22-5.

ppc64le/f23: ./triple-backref: line 15:  6041 Segmentation fault      (core dumped) grep -E '(.?)(.?)(.?)\3\2\1' in > out

ppc64/rawhide: + grep -E '(.?)(.?)(.?)\3\2\1' in
grep: regexec.c:1375: pop_fail_stack: Assertion `num >= 0' failed.
./triple-backref: line 15: 15626 Aborted                 (core dumped) grep -E '(.?)(.?)(.?)\3\2\1' in > out

Comment 3 Marcin Juszkiewicz 2016-01-11 08:48:26 UTC
Same failure on AArch64.

Comment 4 Jaroslav Škarvada 2016-01-11 16:58:09 UTC
(In reply to Rafael Fonseca from comment #2)
> A mockbuild fails on both f23 and rawhide. Version 2.22-5.
> 
> ppc64le/f23: ./triple-backref: line 15:  6041 Segmentation fault      (core
> dumped) grep -E '(.?)(.?)(.?)\3\2\1' in > out
> 
> ppc64/rawhide: + grep -E '(.?)(.?)(.?)\3\2\1' in
> grep: regexec.c:1375: pop_fail_stack: Assertion `num >= 0' failed.
> ./triple-backref: line 15: 15626 Aborted                 (core dumped) grep
> -E '(.?)(.?)(.?)\3\2\1' in > out

This is due to known bug in glibc and it shouldn't be show stopper, because the test is black-listed for build failure:

# The triple-backref test is expected to fail with both the system
# matcher (i.e., with glibc) and with the included matcher.
# Both matchers need to be fixed.
# FIXME-2015: Remove this once the glibc and gnulib bugs are fixed.
XFAIL_TESTS = triple-backref

There must be different failure, isn't it 'pcre-count' test failure?

Comment 5 Rafael Fonseca 2016-01-11 17:14:13 UTC
(In reply to Jaroslav Škarvada from comment #4)
> 
> There must be different failure, isn't it 'pcre-count' test failure?

Yes, you are right.

Comment 6 Fedora Update System 2016-01-12 10:21:30 UTC
grep-2.22-6.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-e5e83f8187

Comment 7 Fedora Update System 2016-01-13 07:22:11 UTC
grep-2.21-9.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8883879d28

Comment 8 Fedora Update System 2016-01-13 07:54:07 UTC
grep-2.22-6.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-e5e83f8187

Comment 9 Fedora Update System 2016-01-14 08:52:07 UTC
grep-2.22-6.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2016-01-24 03:18:15 UTC
grep-2.21-9.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.