Bug 1297431 (CVE-2015-8397)

Summary: CVE-2015-8397 gdcm: Out-of-bounds read in JPEGLSCodec::DecodeExtent
Product: [Other] Security Response Reporter: Adam Mariš <amaris>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: amaris, carnil, lemenkov, mrceresa, sanjay.ankur, sebp
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: gdcm 2.6.2 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-01-02 09:43:56 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1297433    
Bug Blocks:    

Description Adam Mariš 2016-01-11 14:01:32 UTC
It was found that GDCM versions 2.6.0 and 2.6.1 (and possibly previous versions) are prone to an out-of-bounds read vulnerability due to missing checks. The vulnerability occurs during the decoding of JPEG-LS images when the dimensions of the embedded JPEG-LS image (as specified in the JPEG headers) are smaller than the ones of the selected region (set by gdcm::ImageRegionReader::SetRegion and usually based on DICOM header values).

Publiv via:

http://seclists.org/bugtraq/2016/Jan/32

External reference:

http://census-labs.com/news/2016/01/11/gdcm-out-bounds-read-jpeglscodec-decodeextent/

Comment 1 Adam Mariš 2016-01-11 14:01:57 UTC
Created gdcm tracking bugs for this issue:

Affects: fedora-all [bug 1297433]

Comment 2 Sebastian Pölsterl 2016-01-13 19:19:39 UTC
AFAICT, this affects the 2.6 series. GDCM in rawhide has been updated to 2.6.2, which includes the fix, already. The remaining Fedora versions only include gdcm-2.4.x, which is not affected?

Comment 3 Adam Mariš 2016-01-14 09:39:19 UTC
(In reply to Sebastian Pölsterl from comment #2)
> AFAICT, this affects the 2.6 series. GDCM in rawhide has been updated to
> 2.6.2, which includes the fix, already. The remaining Fedora versions only
> include gdcm-2.4.x, which is not affected?

Could you please explain why do you think so? The source code in 2.4.5 looks pretty much the same for given vulnerable functions.