Bug 1299427

Summary: [RFE] - hosted-engine-setup fails identifying hosted-engine storage domain if the gluster entry point is different
Product: [oVirt] ovirt-hosted-engine-setup Reporter: Simone Tiraboschi <stirabos>
Component: Plugins.GlusterAssignee: Simone Tiraboschi <stirabos>
Status: CLOSED NEXTRELEASE QA Contact: meital avital <mavital>
Severity: high Docs Contact:
Priority: unspecified    
Version: 1.3.2.2CC: bugs, didi, lveyde, rmartins, sabose, sbonazzo, stirabos, ylavi
Target Milestone: ---Keywords: FutureFeature
Target Release: ---Flags: ylavi: ovirt-future?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-11-16 19:12:55 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Integration RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1298693, 1393902    
Bug Blocks:    

Description Simone Tiraboschi 2016-01-18 10:55:31 UTC
Description of problem:
I correctly deployed hosted-engine on the first host choosing:
          Please specify the storage you would like to use (glusterfs, iscsi, fc, nfs3, nfs4)[nfs3]: glusterfs
[ INFO  ] Please note that Replica 3 support is required for the shared storage.
          Please specify the full shared storage connection path to use (example: host:/path): c72het20160114g1.localdomain:/engine


Now, deploying an additional host I see:
          Please specify the storage you would like to use (glusterfs, iscsi, fc, nfs3, nfs4)[nfs3]: glusterfs
[ INFO  ] Please note that Replica 3 support is required for the shared storage.
          Please specify the full shared storage connection path to use (example: host:/path): c72het20160114g3.localdomain:/engine                            
[WARNING] Due to several bugs in mount.glusterfs the validation of GlusterFS share cannot be reliable.
[ INFO  ] GlusterFS replica 3 Volume detected
[ INFO  ] Installing on first host

Which is wrong cause 'c72het20160114g1.localdomain:/engine' and 'c72het20160114g3.localdomain:/engine' are just two different entry point for the same gluster volume.

'c72het20160114g1:/engine' fails too.

The user is able to deploy additional hosts only if he/she enters exactly the same entry point he used on the first host.

          Please specify the storage you would like to use (glusterfs, iscsi, fc, nfs3, nfs4)[nfs3]: glusterfs
[ INFO  ] Please note that Replica 3 support is required for the shared storage.
          Please specify the full shared storage connection path to use (example: host:/path): c72het20160114g1.localdomain:/engine
[WARNING] Due to several bugs in mount.glusterfs the validation of GlusterFS share cannot be reliable.
[ INFO  ] GlusterFS replica 3 Volume detected
          The specified storage location already contains a data domain. Is this an additional host setup (Yes, No)[Yes]? 



Version-Release number of selected component (if applicable):
1.3.2.1

How reproducible:
100%

Steps to Reproduce:
1. deploy hosted-engine over gluster on first host
2. try to deploy an additional host using a different entry point for the gluster volume
3.

Actual results:
It fails recognizing the hosted-engine storage domain

Expected results:
It correctly identifies the hosted-engine storage domain

Additional info:
Probably it fails also on NFS moving from hostname:/share to fqdn:/share

Comment 1 Yaniv Kaul 2017-11-16 13:45:59 UTC
How is this RFE affected by the new 4.2 installation flow?

Comment 2 Simone Tiraboschi 2017-11-16 13:59:23 UTC
(In reply to Yaniv Kaul from comment #1)
> How is this RFE affected by the new 4.2 installation flow?

We are not going to rely on auto-import code on engine side by design: the storage domain will be directly created by the engine running on the local VM and so it will already be in its DB.

No need to wait for the engine importing it and so no possible mismatch with the new flow.