Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.

Bug 1301551

Summary: High CPU Load by systemd-udevd with kernel 4.3.3-301.fc23.x86_64
Product: [Fedora] Fedora Reporter: Sven Krämer <sven.kraemer>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 23CC: gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda, mchehab, sven.kraemer
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-10-06 04:45:04 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Sven Krämer 2016-01-25 06:25:54 EST
Description of problem:

we are running several fedora 22 and fedora 23 servers as virual clients under Hyper-V on Windows 2012 servers. After updating to kernel > 4.1.7 of fedora 22 or upgrading to fedora 23 with the latest kernel 4.3.x, the cpu load of the system goes up to 100%. Reason are several systemd-udevd processes. 
udevadm monitor -k show continously the following messages:

KERNEL[2401.353866] add      /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A03:00/device:07/VMBUS:01/vmbus_2244751 (vmbus)
KERNEL[2401.353967] add      /devices/virtual/misc/vmbus!hv_vss (misc)
KERNEL[2401.354405] remove   /devices/virtual/misc/vmbus!hv_vss (misc)
KERNEL[2401.354494] remove   /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A03:00/device:07/VMBUS:01/vmbus_2244751 (vmbus)
KERNEL[2401.354952] add      /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A03:00/device:07/VMBUS:01/vmbus_2244752 (vmbus)
KERNEL[2401.355053] add      /devices/virtual/misc/vmbus!hv_vss (misc)
KERNEL[2401.355413] remove   /devices/virtual/misc/vmbus!hv_vss (misc)
KERNEL[2401.355488] remove   /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A03:00/device:07/VMBUS:01/vmbus_2244752 (vmbus)
KERNEL[2401.355983] add      /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A03:00/device:07/VMBUS:01/vmbus_2244753 (vmbus)
KERNEL[2401.356123] add      /devices/virtual/misc/vmbus!hv_vss (misc)
KERNEL[2401.356502] remove   /devices/virtual/misc/vmbus!hv_vss (misc)
KERNEL[2401.356591] remove   /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A03:00/device:07/VMBUS:01/vmbus_2244753 (vmbus)
KERNEL[2401.357081] add      /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A03:00/device:07/VMBUS:01/vmbus_2244754 (vmbus)
KERNEL[2401.357188] add      /devices/virtual/misc/vmbus!hv_vss (misc)
KERNEL[2401.357560] remove   /devices/virtual/misc/vmbus!hv_vss (misc)
KERNEL[2401.357648] remove   /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A03:00/device:07/VMBUS:01/vmbus_2244754 (vmbus)
KERNEL[2401.358108] add      /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A03:00/device:07/VMBUS:01/vmbus_2244755 (vmbus)
KERNEL[2401.358227] add      /devices/virtual/misc/vmbus!hv_vss (misc)
KERNEL[2401.358613] remove   /devices/virtual/misc/vmbus!hv_vss (misc)
KERNEL[2401.358701] remove   /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A03:00/device:07/VMBUS:01/vmbus_2244755 (vmbus)

If i boot a lower kernel version (for example 4.1.7-200.fc22.x86_64) the problem does not appear.

Version-Release number of selected component (if applicable):

fedora 22 kernel > 4.1.7
fedora 23 kernel 4

How reproducible:

Problem appaers on on all fedora servers under Hyper-V


Steps to Reproduce:
1. Boot fedora with kernel > 4.1.7 under Hyper-V
2. Problem appears

Actual results:
High CPU load by systemd-udevd

Expected results:
normal CPU load

Additional info:
Comment 1 Laura Abbott 2016-09-23 15:53:33 EDT
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 23 kernel bugs.
 
Fedora 23 has now been rebased to 4.7.4-100.fc23.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 24 or 25, and are still experiencing this issue, please change the version to Fedora 24 or 25.
 
If you experience different issues, please open a new bug report for those.
Comment 2 Sven Krämer 2016-10-06 04:45:04 EDT
Hi,

the problem was solved a long time ago by changing a setting in the Hyper-V configuration. For "Integration Services" the point "Backup (volume snapshot)" has benn unchecked. Without this option,m the servers worked fine again.

So that works for me.