Bug 1301912

Summary: Bind starts before all network interfaces are up during boot
Product: Red Hat Enterprise Linux 7 Reporter: John Cameron <john>
Component: bindAssignee: Tomáš Hozza <thozza>
Status: CLOSED DUPLICATE QA Contact: qe-baseos-daemons
Severity: medium Docs Contact:
Priority: unspecified    
Version: 7.2   
Target Milestone: rc   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-05-10 08:16:15 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description John Cameron 2016-01-26 11:16:26 UTC
Description of problem:
  Bind starts before all network interfaces are up during boot,
  Therefore only binds to the interfaces that are already up at the time.
  Particularly when using multiple VLAN interfaces which are
  Brought up one after the other.
Version-Release number of selected component (if applicable):
  bind-chroot-9.9.4-29.el7_2.1.x86_64
How reproducible:
  Always, depending on the amount of interfaces.
Steps to Reproduce:
 Install and configure bind-chroot
 Configure multiple VLAN interfaces with subnets from 10.1.1.1/24 to 10.1.1.10/24
 Reboot
Actual results:
  ss -tnl | grep -w 53
  LISTEN     0      10     127.0.0.1:53                       *:*
Expected results:
  ss -tnl | grep -w 53
  LISTEN     0      10     127.0.0.1:53                       *:*
  LISTEN     0      10     10.1.1.1:53                         *:*
  LISTEN     0      10     10.1.1.2:53                         *:*
  LISTEN     0      10     10.1.1.3:53                         *:*
  LISTEN     0      10     10.1.1.4:53                         *:*
  LISTEN     0      10     10.1.1.5:53                         *:*
  LISTEN     0      10     10.1.1.6:53                         *:*
  LISTEN     0      10     10.1.1.7:53                         *:*
  LISTEN     0      10     10.1.1.8:53                         *:*
  LISTEN     0      10     10.1.1.9:53                         *:*
  LISTEN     0      10     10.1.1.10:53                       *:*
Additional info:
  Fix with :
  
  sed -i "/^Requires=/ aRequires=network.target" /usr/lib/systemd/system/named-chroot.service

Comment 2 Tomáš Hozza 2016-05-10 08:16:15 UTC

*** This bug has been marked as a duplicate of bug 1294506 ***