Bug 130503

Summary: udev - no /dev/dsp
Product: [Fedora] Fedora Reporter: Sammy <umar>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 14:05:12 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Sammy 2004-08-20 16:25:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux; X11; en_US, en_US.UTF-8, en) (KHTML, like Gecko)

Description of problem:
After fixing the initscripts to start udev, making a new initrd image, etc.
I was able to reboot and everything worked except sound.

When I logged into kde interface, either as root or user I got a
message stating that /dev/dsp was not there.

I noticed that the sound modules, which are all in modprobe.conf, were
not loaded e.g. snd-pcm-oss (using artsd and alsa). When I modprobed
I could get  /dev/dsp created and sound worked. But after rebooting
the same problem. Non udev using kernel works fine. If this is a mkinitrd
problem please reassign.

PS: also microcode_ctl is failing at boot saying it could not find a certain device.

Version-Release number of selected component (if applicable):
udev-030-3

How reproducible:
Always

Steps to Reproduce:
1.install kernel using udev
2.login to kde
3.
    

Additional info:
Comment 1 Ralf Ertzinger 2004-08-22 13:27:53 EDT
Also missing are device nodes for SCSI-CD-ROM drives (/dev/scd* or
/dev/sr*), /dev/cdrom* symlinks, /dev/cdwriter* symlinks and /dev/sg*
device nodes.
Comment 2 Harald Hoyer 2004-08-24 05:04:03 EDT

*** This bug has been marked as a duplicate of 130746 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:05:12 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.