Bug 1305471 (CVE-2016-2221, CVE-2016-2222)

Summary: CVE-2016-2221 CVE-2016-2222 wordpress: SSRF and open redirect issues fixed in 4.4.2
Product: [Other] Security Response Reporter: Martin Prpič <mprpic>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: fedora, gwync, ralph
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: wordpress 4.4.2 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-05-09 12:01:46 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1305472, 1305473    
Bug Blocks:    

Description Martin Prpič 2016-02-08 10:49:55 UTC
The following issues were fixed in the 4.4.2 upstream version of WordPress:

- An open redirection attack:
  https://core.trac.wordpress.org/changeset/36444

- A possible SSRF for certain local URIs:
  https://core.trac.wordpress.org/changeset/36435

CVEs assigned in:

http://seclists.org/oss-sec/2016/q1/283

External References:

https://wordpress.org/news/2016/02/wordpress-4-4-2-security-and-maintenance-release/

Comment 1 Martin Prpič 2016-02-08 10:50:24 UTC
Created wordpress tracking bugs for this issue:

Affects: fedora-all [bug 1305472]
Affects: epel-all [bug 1305473]