Bug 1308455

Summary: Couldn't list the project on web console using Edge25
Product: OpenShift Online Reporter: yapei
Component: Management ConsoleAssignee: Jessica Forrester <jforrest>
Status: CLOSED CURRENTRELEASE QA Contact: yapei
Severity: medium Docs Contact:
Priority: medium    
Version: 3.xCC: aos-bugs, ederevea, erich, jforrest, jliggitt, jokerman, mmccomas, whearn, wjiang, yapei
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-05-23 11:09:46 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1303130    
Attachments:
Description Flags
AccessDenied
none
CouldNotLoadProject
none
IEandEdge
none
EdgeSettings none

Description yapei 2016-02-15 04:31:53 EST
Created attachment 1127202 [details]
AccessDenied

Description of problem:
When use Edge25 to access V3 STG web console, couldn't list user projects, neither could do operations.Other browsers work well(Firefox43,Chrome47,Safari9,IE11)

Version-Release number of selected component (if applicable):
V3 STG
Edge25

How reproducible:
Always

Steps to Reproduce:
1.Login V3 STG through web console using Edge browser

Actual results:
1. After login, couldn't list user project, get "Access is denied" error, see attachment.

Expected results:
1. User project should be listed after login, and could do operations on web console

Additional info:
Comment 1 yapei 2016-02-15 04:32 EST
Created attachment 1127203 [details]
CouldNotLoadProject
Comment 2 Jordan Liggitt 2016-02-15 09:45:35 EST
I see a certificate error in the top of the browser... has the certificate been trusted?
Comment 3 yapei 2016-02-16 02:10:57 EST
No, certificate was not trusted, i didn't see an option to add a website (URL) to a Trusted Zone in MS Edge.

will this certificate issue affect listing and other features? I didn't trust the certificate either on Chrome but everything in Chrome works fine.

When I login via CLI using token got from LocalStorage, I could list projects and do operations normally.

is there any possibility this is my network issue?
Comment 5 Jessica Forrester 2016-03-21 16:43:57 EDT
Determined looking at another bug that I think the cert issues with these servers have already been resolved.  I'm fairly certain they had the OOTB self-signed certs at the time this was reported and are now using the right certs.  This issue should be resolved.
Comment 10 yapei 2016-03-23 03:18:26 EDT
Dev Preview Online is not accessible now, will verify when it's available
Comment 12 yapei 2016-03-24 21:20 EDT
Created attachment 1140206 [details]
IEandEdge
Comment 13 yapei 2016-03-24 21:22:52 EDT
Also attach Edge 25 settings on my machine
Comment 14 yapei 2016-03-24 21:23 EDT
Created attachment 1140207 [details]
EdgeSettings
Comment 15 yapei 2016-03-24 21:26:14 EDT
I think there may be some misconfiguration on my Edge25
Comment 16 Jessica Forrester 2016-03-28 14:56:23 EDT
Just updating that I was able to reproduce the issue today, we are looking into it.
Comment 17 Jessica Forrester 2016-04-08 09:05:06 EDT
Just waiting for OPs to apply the workaround for the devpreview cluster.
Comment 19 Jessica Forrester 2016-04-20 11:46:04 EDT
workaround is applied to devpreview cluster, IE11 and Edge 25 are working now
Comment 20 yapei 2016-04-20 21:50:53 EDT
Yes, IE 11 and Edge 25 could list projects on dev-preview-int iteration #3 now
Comment 23 Jessica Forrester 2016-05-09 09:49:52 EDT
*** Bug 1323204 has been marked as a duplicate of this bug. ***