Bug 1309278

Summary: Cluster details page links
Product: Red Hat Storage Console Reporter: Lubos Trilety <ltrilety>
Component: UIAssignee: sankarshan <sankarshan>
Status: CLOSED ERRATA QA Contact: Martin Kudlej <mkudlej>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 2CC: japplewh, mkudlej, nthomas, sankarshan
Target Milestone: ---   
Target Release: 2   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: rhscon-ui-0.0.19-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-08-23 19:47:03 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Lubos Trilety 2016-02-17 11:27:42 UTC
Description of problem:
It is possible to open cluster details page. There are many links on the page however none works.
e.g.
utilization links
openstack sub-menu links
most used pools sub-menu links
hosts, monitors, pgs, osds ... links

Version-Release number of selected component (if applicable):
rhscon-core-0.0.8-4.el7.x86_64
rhscon-ceph-0.0.6-4.el7.x86_64
rhscon-ui-0.0.13-1.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Go to clusters and choose some cluster entry there
2. Check links

Actual results:
No link is working.

Expected results:
All links work as they should.

Additional info:

Comment 4 Martin Kudlej 2016-07-22 10:37:45 UTC
Tested with
ceph-ansible-1.0.5-27.el7scon.noarch
ceph-installer-1.0.14-1.el7scon.noarch
rhscon-ceph-0.0.33-1.el7scon.x86_64
rhscon-core-0.0.34-1.el7scon.x86_64
rhscon-core-selinux-0.0.34-1.el7scon.noarch
rhscon-ui-0.0.48-1.el7scon.noarch
and it works.
If there are any issues they are filed in separated BZs.

Comment 6 errata-xmlrpc 2016-08-23 19:47:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754