Bug 1312483

Summary: Product Content tab on content hosts UI renders nothing
Product: Red Hat Satellite Reporter: Justin Sherrill <jsherril>
Component: APIAssignee: Justin Sherrill <jsherril>
Status: CLOSED ERRATA QA Contact: Sachin Ghai <sghai>
Severity: high Docs Contact:
Priority: unspecified    
Version: 6.2.0CC: bbuckingham, sghai, sthirugn
Target Milestone: UnspecifiedKeywords: Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
URL: http://projects.theforeman.org/issues/13087
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-07-27 09:02:40 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
'Product content' tab renders properly all associated products to contenthost none

Description Justin Sherrill 2016-02-26 20:30:35 UTC
Description of problem:

Visiting the products content tab of the content host details page renders nothing and throws a javascript error:

TypeError: Cannot read property '$promise' of undefined


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Register a content host
2.  Visit the products contents tab of the content host details page


Actual results:
Nothing is rendered


Expected results:
product contents are rendered and user can modify overrides


Additional info:

Comment 1 Justin Sherrill 2016-02-26 20:32:03 UTC
Connecting redmine issue http://projects.theforeman.org/issues/13087 from this bug

Comment 3 Bryan Kearney 2016-02-26 21:03:21 UTC
Upstream bug component is API

Comment 4 Bryan Kearney 2016-02-29 21:03:06 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/13087 has been closed
-------------
Justin Sherrill
Applied in changeset commit:katello|ce95e330d613f433df8eb04d69e41cc5c16cf012.

Comment 6 Sachin Ghai 2016-04-05 12:49:26 UTC
Verified with sat6.2 beta snap6.

I can see 'Proudct content' tab on content hosts details page and it renders properly. I can see all associated products to selected content host. Please see the attached screenshot for verification

Comment 7 Sachin Ghai 2016-04-05 12:50:26 UTC
Created attachment 1143831 [details]
'Product content' tab renders properly all associated products to contenthost

Comment 9 errata-xmlrpc 2016-07-27 09:02:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500