Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.

Bug 1313301

Summary: ipa-server installation fails if java-1.8 is installed
Product: Red Hat Enterprise Linux 6 Reporter: Jaroslav Aster <jaster>
Component: ipaAssignee: IPA Maintainers <ipa-maint>
Status: CLOSED DUPLICATE QA Contact: Namita Soman <nsoman>
Severity: medium Docs Contact: Aneta Šteflová Petrová <apetrova>
Priority: medium    
Version: 6.8CC: pvoborni, rcritten
Target Milestone: rcKeywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugzilla.redhat.com/show_bug.cgi?id=1290535
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
The issue will be documented in BZ#1290535
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-03-11 11:47:39 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jaroslav Aster 2016-03-01 06:10:02 EST
Created attachment 1131876 [details]
ipa-server install log

Description of problem:

ipa-server installation fails if java-1.8 is installed.

Version-Release number of selected component (if applicable):


How reproducible:

100%

Steps to Reproduce:
1. Install java-1.8. It is installed in beaker by default for 6.8 nightly builds.
2. Install ipa-server.

# cat /var/log/ipaserver-install.log
...
2016-03-01T10:52:53Z DEBUG stderr=[error] FAILED run_command("/sbin/service pki-cad restart pki-ca"), exit status=7 output="Stopping pki-ca: [  OK  ]
Incompatible Java version '1.8.0_71'!

    As root, download and install 'jre-1.7.0-openjdk' and run
    'alternatives --set java /usr/lib/jvm/jre-1.7.0-openjdk.x86_64/bin/java'.
"
...

Actual results:

Installation of ipa-server fails.

Expected results:

Installation of ipa-server passes.

Additional info:

Log file is attached.
Comment 1 Petr Vobornik 2016-03-01 07:00:12 EST
IPA, or rather PKI server, supports only Java 1.7 on RHEL 6.

The error message clearly says the way to fix the issue:

     As root, download and install 'jre-1.7.0-openjdk' and run
    'alternatives --set java /usr/lib/jvm/jre-1.7.0-openjdk.x86_64/bin/java'.
Comment 2 Petr Vobornik 2016-03-01 10:01:56 EST
Reopening, IPA team agreed that IPA installer should at least print the pkispawn error message into console output so that user will know what is happening without checking logs.

Note: if discussion/query in Bug 1290535, comment 20 ends with a fix on pki-side then this bug will be closed again because it won't be needed.
Comment 3 Petr Vobornik 2016-03-11 11:47:39 EST
In bug 1290535 PKI server will be modified to run with java 1.7 and not print the error message in comment 1.

Fetching and printing the PKI output is therefore not needed -> closing.

*** This bug has been marked as a duplicate of bug 1290535 ***