Bug 1314394

Summary: Composite views allow promotions beyond what they should
Product: Red Hat Satellite Reporter: Bryan Kearney <bkearney>
Component: Content ViewsAssignee: Katello Bug Bin <katello-bugs>
Status: CLOSED ERRATA QA Contact: Corey Welton <cwelton>
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0.6CC: andrew.schofield, bbuckingham, bkearney, cwelton, ehelms, kabbott, katello-qa-list, mmccune, sghai, xdmoon
Target Milestone: UnspecifiedKeywords: Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
URL: http://projects.theforeman.org/issues/13057
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1174237 Environment:
Last Closed: 2016-03-22 15:44:50 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1174237    
Bug Blocks:    

Comment 2 Corey Welton 2016-03-11 14:49:18 UTC
Verified in 6.1.8 Compose 1

when restrict_composite_view = 'true', user cannot promote to any environment of which the contained content is not already a member, and an appropriate error message is thrown

when restrict_composite_view = 'false', no such restriction exists and promotion is allowed.

Comment 4 errata-xmlrpc 2016-03-22 15:44:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0475