Bug 1318109

Summary: [RFE] Please show Wubi table code when in pinyin mode
Product: [Fedora] Fedora Reporter: Mike FABIAN <mfabian>
Component: ibus-tableAssignee: Mike FABIAN <mfabian>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 23CC: dchen, i18n-bugs, kent.neo, me, mfabian, pwu, shawn.p.huang
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: ibus-table-1.9.12-1.fc24 ibus-table-1.9.12-1.fc23 ibus-table-1.9.12-1.fc22 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-04-04 17:26:35 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
show-table-codes.png
none
0001-Show-the-table-code-in-the-candidate-list-when-pinyi.patch none

Description Mike FABIAN 2016-03-16 06:20:09 UTC
https://github.com/ibus/ibus/issues/1846

Peng Wu> In China, when people use Wubi to input some characters,
Peng Wu> they may forget the Wubi code to input Chinese characters,
Peng Wu> then they use pinyin mode to input that character.
Peng Wu> 
Peng Wu> But he may want to know the Wubi code to input that character,
Peng Wu> next time he will use Wubi code to input it.
Peng Wu> 
Peng Wu> Fcitx Wubi will display Wubi table code when in pinyin mode.
Peng Wu> Could ibus-table support this feature?

Comment 1 Mike FABIAN 2016-03-16 08:06:28 UTC
Created attachment 1136897 [details]
show-table-codes.png

cangjie5 shown on left, wubi-jidian on the right.

Comment 2 Mike FABIAN 2016-03-16 08:08:36 UTC
Created attachment 1136899 [details]
0001-Show-the-table-code-in-the-candidate-list-when-pinyi.patch

Comment 3 Mike FABIAN 2016-03-16 08:10:00 UTC
The attachment in comment#1 shows how it looks like with the patch in comment#2.

Comment 4 Fedora Update System 2016-03-16 09:18:54 UTC
ibus-table-1.9.12-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-9668f9969e

Comment 5 Fedora Update System 2016-03-16 09:19:31 UTC
ibus-table-1.9.12-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-92bc7d819a

Comment 6 Fedora Update System 2016-03-16 09:20:07 UTC
ibus-table-1.9.12-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ebb9df5b07

Comment 7 Fedora Update System 2016-03-18 14:59:46 UTC
ibus-table-1.9.12-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ebb9df5b07

Comment 8 Fedora Update System 2016-03-18 23:56:07 UTC
ibus-table-1.9.12-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-9668f9969e

Comment 9 Fedora Update System 2016-03-19 01:26:53 UTC
ibus-table-1.9.12-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-92bc7d819a

Comment 10 Fedora Update System 2016-04-04 17:26:31 UTC
ibus-table-1.9.12-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2016-04-05 13:54:16 UTC
ibus-table-1.9.12-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2016-04-05 14:18:50 UTC
ibus-table-1.9.12-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2016-04-05 16:21:20 UTC
ibus-table-1.9.12-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.