Bug 1318423

Summary: Ensure that the capsule installer sets up a standard pulp server
Product: Red Hat Satellite 6 Reporter: John Mitsch <jomitsch>
Component: Content ManagementAssignee: satellite6-bugs <satellite6-bugs>
Status: CLOSED ERRATA QA Contact: Kedar Bidarkar <kbidarka>
Severity: high Docs Contact:
Priority: unspecified    
Version: 6.0.4CC: bbuckingham, ehelms, jomitsch, kbidarka, sthirugn
Target Milestone: UnspecifiedKeywords: FutureFeature, Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
URL: http://projects.theforeman.org/issues/13200
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-07-27 09:27:51 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1318421, 1321137    
Bug Blocks:    

Description John Mitsch 2016-03-16 20:19:08 UTC

Comment 1 John Mitsch 2016-03-16 20:19:10 UTC
Created from redmine issue http://projects.theforeman.org/issues/13200

Comment 3 Bryan Kearney 2016-03-16 22:09:45 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/13200 has been closed
-------------
John Mitsch
Applied in changeset commit:puppet-capsule|233e31a9dea0053731ff64cb5ac6ddf92eef7172.

Comment 4 John Mitsch 2016-03-18 13:52:44 UTC
To test this, make sure capsule sync and the gpg key for an isolated client work fine.

Comment 7 John Mitsch 2016-04-01 13:49:42 UTC
Kedar,

yes, that should be enough to verify this bug.

-John

Comment 8 Kedar Bidarkar 2016-04-15 17:31:41 UTC
~]# subscription-manager refresh
All local data refreshed
[root@kbrhel72c1m ~]# yum repolist
Loaded plugins: package_upload, product-id, search-disabled-repos, subscription-manager
Default_Organization_rhel7_prd_tools_rhel7_sattools_repo                                                                                                                                    | 2.1 kB  00:00:00     
Default_Organization_rhel_zoo_prd_rhel_zoo_repo                                                                                                                                             | 2.1 kB  00:00:00     
rhel-7-server-rpms                                                                                                                                                                          | 2.1 kB  00:00:00     
(1/3): Default_Organization_rhel_zoo_prd_rhel_zoo_repo/updateinfo                                                                                                                           |  362 B  00:00:00     
(2/3): Default_Organization_rhel_zoo_prd_rhel_zoo_repo/group                                                                                                                                | 1.9 kB  00:00:00     
(3/3): Default_Organization_rhel_zoo_prd_rhel_zoo_repo/primary                                                                                                                              | 3.6 kB  00:00:00     
Default_Organization_rhel_zoo_prd_rhel_zoo_repo                                                                                                                                                              32/32
repo id                                                                                                       repo name                                                                                      status
Default_Organization_rhel7_prd_tools_rhel7_sattools_repo                                                      rhel7_sattools_repo                                                                               680
Default_Organization_rhel_zoo_prd_rhel_zoo_repo                                                               rhel_zoo_repo                                                                                      32
rhel-7-server-rpms/7Server/x86_64                                                                             Red Hat Enterprise Linux 7 Server (RPMs)                                                       10,612
repolist: 11,324
[root@kbrhel72c1m ~]# yum install cow
Loaded plugins: package_upload, product-id, search-disabled-repos, subscription-manager
Default_Organization_rhel7_prd_tools_rhel7_sattools_repo                                                                                                                                    | 2.1 kB  00:00:00     
Default_Organization_rhel_zoo_prd_rhel_zoo_repo                                                                                                                                             | 2.1 kB  00:00:00     
rhel-7-server-rpms                                                                                                                                                                          | 2.1 kB  00:00:00     
Resolving Dependencies
--> Running transaction check
---> Package cow.noarch 0:2.2-3 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

===================================================================================================================================================================================================================
 Package                               Arch                                     Version                                    Repository                                                                         Size
===================================================================================================================================================================================================================
Installing:
 cow                                   noarch                                   2.2-3                                      Default_Organization_rhel_zoo_prd_rhel_zoo_repo                                   2.4 k

Transaction Summary
===================================================================================================================================================================================================================
Install  1 Package

Total download size: 2.4 k
Installed size: 42  
Is this ok [y/d/N]: y
Downloading packages:
warning: /var/cache/yum/x86_64/7Server/Default_Organization_rhel_zoo_prd_rhel_zoo_repo/packages/cow-2.2-3.noarch.rpm: Header V3 RSA/SHA1 Signature, key ID f78fb195: NOKEY       ]  0.0 B/s |    0 B  --:--:-- ETA 
Public key for cow-2.2-3.noarch.rpm is not installed
cow-2.2-3.noarch.rpm                                                                                                                                                                        | 2.4 kB  00:00:00     
Retrieving key from https://abc.redhat.com/katello/api/repositories/23/gpg_key_content
Importing GPG key 0xF78FB195:
 Userid     : "Dummy Packages Generator <admin@zoo.example.com>"
 Fingerprint: f918 5f7e 927a 00fb a8eb 65b5 ef85 cce3 f78f b195
 From       : https://abc.redhat.com/katello/api/repositories/23/gpg_key_content
Is this ok [y/N]: y
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : cow-2.2-3.noarch                                                                                                                                                                                1/1 
Uploading Package Profile
  Verifying  : cow-2.2-3.noarch                                                                                                                                                                                1/1 

Installed:
  cow.noarch 0:2.2-3                                                                                                                                                                                               

Complete!



VERIFIED With sat62-snap8.1

Comment 10 errata-xmlrpc 2016-07-27 09:27:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501