Bug 1318651

Summary: kernel 4.5.0-0.rc7.git0.2.fc24 doesn't boot on Banana Pi
Product: [Fedora] Fedora Reporter: Lukas Brabec <lbrabec>
Component: uboot-toolsAssignee: Dennis Gilmore <dennis>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 24CC: awilliam, dan, dennis, gansalmon, itamar, jdisnard, jonathan, kparal, madhu.chinakonda, mchehab, pbrobinson
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedFreezeException
Fixed In Version: uboot-tools-2016.03-3.fc24 uboot-tools-2016.03-4.fc24 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-03-23 19:59:16 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 245418, 1230432    
Attachments:
Description Flags
screenshot of u-boot none

Description Lukas Brabec 2016-03-17 12:54:25 UTC
Created attachment 1137383 [details]
screenshot of u-boot

Description of problem:
Using image Fedora-Minimal-armhfp-24_Alpha-5-sda.raw.xz (Fedora 24 Alpha 1.5), I'm unable to boot on Banana Pi. All I get is "Starting kernel ..." in u-boot. 


Version-Release number of selected component (if applicable):

kernel 4.5.0-0.rc7.git0.2.fc24
u-boot 2016.03-rc3


Steps to Reproduce:
1. download Fedora 24 Alpha 1.5 arm image (from [1])
2. $ fedora-arm-image-installer --media=/dev/mmcblk0 --target=Bananapi --image=Fedora-Minimal-armhfp-24_Alpha-5-sda.raw.xz
3. insert into Banana Pi and boot.

Actual results:
Fedora doesn't boot.

Expected results:
Fedora boots.



[1] https://kojipkgs.fedoraproject.org/compose/24/Fedora-24-20160316.3/compose/Spins/armhfp/images/Fedora-Minimal-armhfp-24_Alpha-5-sda.raw.xz

Comment 1 Fedora Blocker Bugs Application 2016-03-21 18:15:20 UTC
Proposed as a Freeze Exception for 24-alpha by Fedora user pbrobinson using the blocker tracking app because:

 The uboot-tools-2016.03-3 build fixes booting for a number of AllWinner ARM devices. It would be good to have this accepted as a FE, the patches added are self contained and straight forward so there's minimal risk to other ARMv7 devices, and it doesn't impact other architectures.

Comment 2 Peter Robinson 2016-03-21 18:17:54 UTC
this build should fix issues http://koji.fedoraproject.org/koji/taskinfo?taskID=13413559

Comment 3 Fedora Update System 2016-03-21 23:22:41 UTC
uboot-tools-2016.03-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-bdd2592ee5

Comment 4 Adam Williamson 2016-03-22 05:00:40 UTC
+1 FE, targeted hardware enablement is worthwhile.

Comment 5 Kamil Páral 2016-03-22 07:49:51 UTC
+1 FE

Comment 6 Lukas Brabec 2016-03-22 07:56:13 UTC
+1 FE

Comment 7 Kamil Páral 2016-03-22 07:56:49 UTC
Accepted as a freeze exception.

Comment 8 Fedora Update System 2016-03-22 16:55:48 UTC
uboot-tools-2016.03-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-bdd2592ee5

Comment 9 Fedora Update System 2016-03-23 17:11:30 UTC
uboot-tools-2016.03-4.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-2142bb2db2

Comment 10 Fedora Update System 2016-03-23 19:55:10 UTC
uboot-tools-2016.03-4.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-2142bb2db2

Comment 11 Fedora Update System 2016-03-23 19:59:12 UTC
uboot-tools-2016.03-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2016-03-29 19:33:37 UTC
uboot-tools-2016.03-4.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.